summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-03-29 16:53:45 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-29 15:46:35 +0000
commit09fd2eddd43d660e4fb890bdb818021ec7279eba (patch)
tree55b1ab24cb2f79e396d55a100c92ef8cb1b78b34 /meta-app-framework
parent2f6d1e8d3c1b19737d26a3979942c6defc5a8408 (diff)
Fix virtual provider for webruntime
A recipe that is to be used as virtual provider needs to declare this in a PROVIDES += 'virtual/foo' statement. The selection then happens through a PREFERRED_PROVIDER. Add the missing PROVIDES. Additionally we found that in case of web-runtime, _R_PROVIDES is not reflecting the PROVIDES as expected and added the necessary override there, too. Kudos to co-investigator Stéphane Desneux. Change-Id: Ic9224ea122c21dab6ab2e7e515d6ac4d0417ef57 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb b/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
index fa149875c..90c72eccf 100644
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
+++ b/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
@@ -14,6 +14,10 @@ SRC_URI = "\
RDEPENDS_${PN} = "qtwebkit-qmlplugins"
+PROVIDES += "virtual/webruntime"
+# add also RPROVIDES to satisfy the packagegroup
+RPROVIDES_${PN} += "virtual/webruntime"
+
do_configure() {
:
}