summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-05-09 11:49:57 -0700
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-05-12 21:50:40 +0000
commit272689b49e33a6be03404115d41e449d948b2665 (patch)
treec87efa07d53eec2d1bb3d30ba9c782dd72621225 /meta-app-framework
parent379f0a11a76b7e892a9395a5540afb4886ea8541 (diff)
web-runtime: add missing runtime dependencies
web-runtime calls into qml functionality that it does not explicitly RDEPEND on. Fix this. Change-Id: I6523d6ff2b152ca120c4cd4ed0fa60710df16bc6 Signed-off-by: Martin Kelly <mkelly@xevo.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9335 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb b/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
index 90c72eccf..c58daea30 100644
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
+++ b/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
@@ -12,7 +12,12 @@ SRC_URI = "\
file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
"
-RDEPENDS_${PN} = "qtwebkit-qmlplugins"
+RDEPENDS_${PN} = "\
+ qtdeclarative-tools \
+ qtwebkit-qmlplugins \
+ qtwayland-qmlplugins \
+ qtquickcontrols-qmlplugins \
+"
PROVIDES += "virtual/webruntime"
# add also RPROVIDES to satisfy the packagegroup