summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
authorPhong Tran <tranmanphong@gmail.com>2017-02-23 23:41:45 +0700
committerStephane Desneux <stephane.desneux@iot.bzh>2017-03-27 15:33:40 +0200
commit2af22bf84f7c7b1b1047a6d451aa0ac3a8b35c5c (patch)
tree4c108a30842d906b57c224511a08360c9006665f /meta-app-framework
parent2645ceca2399368af20c1b1222575bcb7c6cb613 (diff)
Fix the error of homescreen for QEMU x86-64
libEGL.so is not availabe in QEMU x86-64 env. This make the afm-user-daemon service is loaded failure. This make the homescreen fail to load. Remove LD_PRELOAD of libEGL.so for QEMU x86-64. Change-Id: Iba9a904cc7e4000861ec0e0d6f5c22f48428b954 Signed-off-by: Phong Tran <tranmanphong@gmail.com> Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index c7b8ba440..6a1d36a99 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -82,6 +82,10 @@ do_install_append() {
install -m 0755 ${WORKDIR}/afm-install ${D}${bindir}
}
+do_install_append_qemux86-64() {
+ sed -i -e '/LD_PRELOAD=\/usr\/lib\/libEGL.so/d' ${D}${systemd_user_unitdir}/afm-user-daemon.service
+}
+
do_install_append_smack () {
install -d ${D}/${sysconfdir}/smack/accesses.d
cat > ${D}/${sysconfdir}/smack/accesses.d/default-access-domains-no-user <<EOF