summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common/recipes-automotive
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:22:37 +0200
committerGerrit Code Review <gerrit@172.30.200.200>2016-09-01 22:42:01 +0000
commit85844f4d250d1a45129455c76e467e38d3b3e92c (patch)
treeeae6ed37b93870ea9d839834c0bfede384882331 /meta-ivi-common/recipes-automotive
parentbcd5d1e36b83d39ea57ffa8b271a2256eaed49ff (diff)
Changes for building with YP 2.1.1 'krogoth'
Notable changes: - Update poky-agl.conf for YP 2.1 krogoth - change mesa bbappend to mesa_11 - TODO: check need for gallium, or replace with DRM see SPEC-237 - remote linux-yocto_3.14 as it is no longer shipped with YP 2.1 - rtl-sdr got a fix included for its packageconfig file - update 0001-disable-when-booting-over-nfs.patch - update checksums for ft2demo - TODO: check installation of test binaries - automotive-message-broker needed a workaround in the recipe - TODO: fix package and recipe - wayland-ivi-extension fix for use of autotools _AND_ cmake at the same time: only use cmake - port pulseaudio_6.0.bbappend to pulseaudio_8.0.bbappend - TODO: check patches and forward-port - agl-audio-plugin is currently disabled until ported to pulseaudio 8.0 - gstreamer1.0_1.2.3 is only used by meta-renesas, thus move it there - update dlt-daemon to 2.15 TODO: - check values in poky-agl.conf - check mesa for needed bbappends on other boards (tested qemux86 and qemux86_64) - check pulsaudio bbappend and forward-port patches (patches disabled!) - check agl-audio-plugin and forward-port (build disabled!) - check freetype bbappend wrt. installation path of test binaries - check automotive-message-broker wrt installation routines for libraries (QA failure) - check wayland-ivi-extension build and capabilities Change-Id: I553e03cc37348cba2fc4a022820157c78bb184d3 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-ivi-common/recipes-automotive')
-rw-r--r--meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb13
-rw-r--r--meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc33
2 files changed, 34 insertions, 12 deletions
diff --git a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
index dee6f5980..fb1cb774f 100644
--- a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
+++ b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
@@ -38,6 +38,19 @@ do_install_append() {
if [ "${@bb.utils.contains('PACKAGECONFIG', 'use_gps', 'use_gps', '', d)}" = "use_gps" ]; then
install -m 0644 ${WORKDIR}/gps ${D}/${sysconfdir}/ambd/plugins.d
fi
+
+ # Grmbl - heck gotta fix library installations ?!? WTF !
+ # GO FIX YOUR INSTALLATION ROUTINES PLEASE. ;) (jsmoeller)
+ # HACK-ALARM:
+ ls -alh ${D}${libdir}
+ if test -e ${D}${libdir}/libamb-qt.so -a ! -L ${D}${libdir}/libamb-qt.so ; then
+ mv ${D}${libdir}/libamb-qt.so ${D}${libdir}/libamb-qt.so.0
+ ln -sf libamb-qt.so.0 ${D}${libdir}/libamb-qt.so
+ fi
+ if test -e ${D}${libdir}/libamb-plugins-common.so -a ! -L ${D}${libdir}/libamb-plugins-common.so ; then
+ mv ${D}${libdir}/libamb-plugins-common.so ${D}${libdir}/libamb-plugins-common.so.0
+ ln -sf libamb-plugins-common.so.0 ${D}${libdir}/libamb-plugins-common.so
+ fi
}
FILES_${PN} += " ${systemd_unitdir}/ambd.service \
diff --git a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc
index 377e9ebc1..88adfab49 100644
--- a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc
+++ b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc
@@ -1,8 +1,12 @@
LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=b42382de5d854b9bb598acf2e8827de3"
-SRC_URI = "git://github.com/CogentEmbedded/automotive-message-broker.git;protocol=https;branch=master"
-SRCREV = "58569fac42bb8b6e1ad208caef5db8a51befc87f"
+#SRC_URI = "git://github.com/CogentEmbedded/automotive-message-broker.git;protocol=https;branch=master"
+#SRCREV = "58569fac42bb8b6e1ad208caef5db8a51befc87f"
+
+SRC_URI = "git://github.com/otcshare/automotive-message-broker.git;branch=0.14"
+SRCREV = "c216955d16ca275159891cad296217094d972390"
+#SRCREV = "c26819073d2a1444a156e4d2e3b61bef81663ea5"
PV = "0.14+git${SRCPV}"
@@ -10,18 +14,23 @@ PV = "0.14+git${SRCPV}"
# hash:58569fac42bb8b6e1ad208caef5db8a51befc87f(main branch) and
# hash:8f761e02172544212915c82b7e8dd8d4dd1281a6(dev_0.14_2)
SRC_URI += " \
- file://0001-Improve-backward-compatibility-with-old-linaro-gcc.patch \
- file://0002-Fix-library-versioning.patch \
- file://0003-AmbSignalMapper-fix-can-interface-specification.patch \
- file://0004-cansocketbcm-Fix-reading-of-frames-in-case-of-RX_TIM.patch \
- file://0005-ambctl-remove-unnecessary-dependency-on-glib-introsp.patch \
- file://0006-cangen-Implement-basic-handling-of-RX_TIMEOUT.patch \
- file://0007-WORKAROUND-Allow-amb-qt-binding-to-work-in-case-of-m.patch \
- file://0008-Add-simple-Qt-QML-example.patch \
- file://0009-Add-Pressure-property-to-BrakeOperation.patch \
- file://0001-Fix-build-issues-while-bitbake-without-meta-qt5-laye.patch \
file://ambd.service \
file://gps \
"
+# file://0001-Improve-backward-compatibility-with-old-linaro-gcc.patch
+# file://0002-Fix-library-versioning.patch
+# file://0003-AmbSignalMapper-fix-can-interface-specification.patch
+# file://0004-cansocketbcm-Fix-reading-of-frames-in-case-of-RX_TIM.patch
+# file://0005-ambctl-remove-unnecessary-dependency-on-glib-introsp.patch
+# file://0006-cangen-Implement-basic-handling-of-RX_TIMEOUT.patch
+# file://0007-WORKAROUND-Allow-amb-qt-binding-to-work-in-case-of-m.patch
+# file://0008-Add-simple-Qt-QML-example.patch
+# file://0009-Add-Pressure-property-to-BrakeOperation.patch
+# file://0001-Fix-build-issues-while-bitbake-without-meta-qt5-laye.patch
S = "${WORKDIR}/git"
+
+INSANE_SKIP_{PN} += "dev-elf"
+INSANE_SKIP_{PN} += "dev-deps"
+INSANE_SKIP_{PN}-devel += "dev-elf"
+INSANE_SKIP_{PN}-devel += "dev-deps"