aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core.bb
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2015-10-02 14:02:06 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2015-10-02 14:03:57 +0900
commitf5c979f2af5c4d343939e38ea4e5e484049803eb (patch)
tree7a26a2174291bdfc2d876eb024eff6795c32884b /meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core.bb
parent06963e9e7e72e5bf730d08ed4b83bc12dcee4ad6 (diff)
Reworking packagegroups of AGL Distribution
The recipe files and thier names are reworked by design of AGL packagegroup. For more details, see 'Packagegroups' section in README.md. Change-Id: Ie7cd0efd1200c1a78d30ad6a834b9482487f0089 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core.bb')
-rw-r--r--meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core.bb b/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core.bb
new file mode 100644
index 000000000..b3cff10a6
--- /dev/null
+++ b/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core.bb
@@ -0,0 +1,23 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "A set of packagegroups which contain common packages required by AGL Distribution"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-ivi-common-core \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ packagegroup-ivi-common-core-automotive \
+ packagegroup-ivi-common-core-connectivity \
+ packagegroup-ivi-common-core-graphics \
+ packagegroup-ivi-common-core-multimedia \
+ packagegroup-ivi-common-core-navi-lbs \
+ packagegroup-ivi-common-core-os-commonlibs \
+ packagegroup-ivi-common-core-speech-services \
+ packagegroup-ivi-common-core-security \
+ packagegroup-ivi-common-core-kernel \
+ "