summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:22:37 +0200
committerGerrit Code Review <gerrit@172.30.200.200>2016-09-01 22:42:01 +0000
commit85844f4d250d1a45129455c76e467e38d3b3e92c (patch)
treeeae6ed37b93870ea9d839834c0bfede384882331 /meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
parentbcd5d1e36b83d39ea57ffa8b271a2256eaed49ff (diff)
Changes for building with YP 2.1.1 'krogoth'
Notable changes: - Update poky-agl.conf for YP 2.1 krogoth - change mesa bbappend to mesa_11 - TODO: check need for gallium, or replace with DRM see SPEC-237 - remote linux-yocto_3.14 as it is no longer shipped with YP 2.1 - rtl-sdr got a fix included for its packageconfig file - update 0001-disable-when-booting-over-nfs.patch - update checksums for ft2demo - TODO: check installation of test binaries - automotive-message-broker needed a workaround in the recipe - TODO: fix package and recipe - wayland-ivi-extension fix for use of autotools _AND_ cmake at the same time: only use cmake - port pulseaudio_6.0.bbappend to pulseaudio_8.0.bbappend - TODO: check patches and forward-port - agl-audio-plugin is currently disabled until ported to pulseaudio 8.0 - gstreamer1.0_1.2.3 is only used by meta-renesas, thus move it there - update dlt-daemon to 2.15 TODO: - check values in poky-agl.conf - check mesa for needed bbappends on other boards (tested qemux86 and qemux86_64) - check pulsaudio bbappend and forward-port patches (patches disabled!) - check agl-audio-plugin and forward-port (build disabled!) - check freetype bbappend wrt. installation path of test binaries - check automotive-message-broker wrt installation routines for libraries (QA failure) - check wayland-ivi-extension build and capabilities Change-Id: I553e03cc37348cba2fc4a022820157c78bb184d3 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch')
-rw-r--r--meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch25
1 files changed, 11 insertions, 14 deletions
diff --git a/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
index df762f33d..685dfcddc 100644
--- a/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
+++ b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
@@ -9,19 +9,16 @@ Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
systemd/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/systemd/CMakeLists.txt b/systemd/CMakeLists.txt
-index a9838e4..c8feae5 100644
---- a/systemd/CMakeLists.txt
-+++ b/systemd/CMakeLists.txt
-@@ -16,7 +16,7 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e6b44a2..0e885bf 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -175,7 +175,7 @@ if(WITH_SYSTEMD OR WITH_SYSTEMD_WATCHDOG OR WITH_SYSTEMD_JOURNAL)
- if(WITH_SYSTEMD)
+ set( systemd_SRCS ${CMAKE_SOURCE_DIR}/systemd/3rdparty/sd-daemon.c)
-- set(SYSTEMD_CONFIGURATIONS_FILES_DIR ${CMAKE_INSTALL_PREFIX}/lib/systemd/system )
-+ set(SYSTEMD_CONFIGURATIONS_FILES_DIR /lib/systemd/system )
-
- if(WITH_SYSTEMD_WATCHDOG)
- set( DLT_WatchdogSec 2 )
---
-1.9.3
-
+- set(SYSTEMD_UNITDIR "${CMAKE_INSTALL_PREFIX}/lib/systemd/system" CACHE PATH
++ set(SYSTEMD_UNITDIR "/lib/systemd/system" CACHE PATH
+ "Set directory to install systemd unit files")
+
+ add_subdirectory( systemd )