summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell-config.bb
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@iot.bzh>2015-09-29 18:56:55 +0000
committerManuel Bachmann <mbc@iot.bzh>2015-09-30 03:47:01 +0000
commit06963e9e7e72e5bf730d08ed4b83bc12dcee4ad6 (patch)
tree45c7218aa64a5fdc07e0d2dbf84eb30e3730bd58 /meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell-config.bb
parente0cb14ae3f8eac1fb4c9c48b90e60115a0468985 (diff)
Provide Weston IVI-Shell, run it on demand
Weston IVI-Shell provides a shell plugin for Weston, mapping the GENIVI API (http://www.genivi.org) for In-Vehicle Infotainment. This is a code backport from Weston 1.9.0 "release". This patch makes sure that Weston IVI-Shell always gets built ; it will not be started, however, unless the builder specifies the following in his "conf/local.conf" file : IMAGE_INSTALL_append = " \ weston-ivi-shell-config \ " or manually overwrites the "/etc/xdg/weston/weston.ini" file with a correct one. Change-Id: I033094aaf8ac2c6299bd354b362b24ffc9ed8577 Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh>
Diffstat (limited to 'meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell-config.bb')
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell-config.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell-config.bb b/meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell-config.bb
new file mode 100644
index 000000000..08921ef8e
--- /dev/null
+++ b/meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell-config.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Configuration file for Weston IVI-Shell"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
+
+FILESEXTRAPATHS_prepend := ":${THISDIR}/weston-ivi-shell:"
+
+SRC_URI = "file://weston.ini.ivi-shell"
+
+do_install() {
+ install -d ${D}${sysconfdir}/xdg/weston
+ install -m644 ${WORKDIR}/weston.ini.ivi-shell ${D}${sysconfdir}/xdg/weston/weston.ini
+}
+
+RDEPENDS_${PN} = "weston"