summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common/recipes-graphics/wayland/weston_1.5.0.bbappend
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@iot.bzh>2015-09-29 18:56:55 +0000
committerManuel Bachmann <mbc@iot.bzh>2015-09-30 03:47:01 +0000
commit06963e9e7e72e5bf730d08ed4b83bc12dcee4ad6 (patch)
tree45c7218aa64a5fdc07e0d2dbf84eb30e3730bd58 /meta-ivi-common/recipes-graphics/wayland/weston_1.5.0.bbappend
parente0cb14ae3f8eac1fb4c9c48b90e60115a0468985 (diff)
Provide Weston IVI-Shell, run it on demand
Weston IVI-Shell provides a shell plugin for Weston, mapping the GENIVI API (http://www.genivi.org) for In-Vehicle Infotainment. This is a code backport from Weston 1.9.0 "release". This patch makes sure that Weston IVI-Shell always gets built ; it will not be started, however, unless the builder specifies the following in his "conf/local.conf" file : IMAGE_INSTALL_append = " \ weston-ivi-shell-config \ " or manually overwrites the "/etc/xdg/weston/weston.ini" file with a correct one. Change-Id: I033094aaf8ac2c6299bd354b362b24ffc9ed8577 Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh>
Diffstat (limited to 'meta-ivi-common/recipes-graphics/wayland/weston_1.5.0.bbappend')
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/weston_1.5.0.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-graphics/wayland/weston_1.5.0.bbappend b/meta-ivi-common/recipes-graphics/wayland/weston_1.5.0.bbappend
new file mode 100644
index 000000000..264b6ab6d
--- /dev/null
+++ b/meta-ivi-common/recipes-graphics/wayland/weston_1.5.0.bbappend
@@ -0,0 +1,23 @@
+FILESEXTRAPATHS_prepend := ":${THISDIR}/weston-ivi-shell:"
+
+SRC_URI_append = " \
+ file://Backport-IVI-Shell-from-Weston-1.9.0-to-1.5.0.patch \
+ file://data/background.png \
+ file://data/fullscreen.png \
+ file://data/home.png \
+ file://data/icon_ivi_clickdot.png \
+ file://data/icon_ivi_flower.png \
+ file://data/icon_ivi_simple-egl.png \
+ file://data/icon_ivi_simple-shm.png \
+ file://data/icon_ivi_smoke.png \
+ file://data/panel.png \
+ file://data/random.png \
+ file://data/sidebyside.png \
+ file://data/tiling.png \
+ "
+
+EXTRA_OECONF_append = " --enable-ivi-shell"
+
+do_compile_prepend() {
+ cp -f ${WORKDIR}/data/* ${S}/data
+}