summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-06-17 14:35:16 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-06-19 19:43:07 +0000
commit86180838e730d7ef96256f2c1e49081072ad84b6 (patch)
tree43ca21ca5bde0689dfe948587faef8dd8e83b90d /meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
parent9cf81bd919922b4b558c9108b53680786b2065c9 (diff)
meta-ivi-common: amend freetype recipe to package freetype-demos
Binaries present in ft2demos source project are packaged in freetype-demos to satisfy JTA dependencies (job Functional.ft2demos) Change-Id: I0f2088c1d1e8586617f66292de652f3783f3f00f Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-ivi-common/recipes-test/freetype/freetype_%.bbappend')
-rw-r--r--meta-ivi-common/recipes-test/freetype/freetype_%.bbappend28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend b/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
new file mode 100644
index 000000000..835580f1d
--- /dev/null
+++ b/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
@@ -0,0 +1,28 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI =+ "${SOURCEFORGE_MIRROR}/freetype/ft2demos-${PV}.tar.bz2;name=ft2demos \
+ file://0001-Makefile-dont-build-gfx-demos.patch;patchdir=../ft2demos-${PV} \
+ "
+SRC_URI[ft2demos.md5sum] = "c6c209b37f10621d6ff100620b8292b4"
+SRC_URI[ft2demos.sha256sum] = "f8f4bc2a2e76e0dbe61838e452c5a7daf1d4bd9dfa44691940bf308f776d32b6"
+
+PACKAGES =+ "${PN}-demos"
+
+do_compile_append () {
+ oe_runmake -C ${WORKDIR}/ft2demos-${PV} TOP_DIR=${WORKDIR}/${PN}-${PV}
+}
+
+do_install_append () {
+ install -d -m 0755 ${D}/${bindir}
+ for x in ftbench ftdump ftlint ftvalid ttdebug; do
+ install -m 0755 ${WORKDIR}/ft2demos-${PV}/bin/$x ${D}/${bindir}
+ done
+}
+
+FILES_${PN}-demos = "\
+ ${bindir}/ftbench \
+ ${bindir}/ftdump \
+ ${bindir}/ftlint \
+ ${bindir}/ftvalid \
+ ${bindir}/ttdebug \
+"