summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common/recipes-test/freetype/freetype_2.8.bbappend
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2017-12-13 11:29:19 +0000
committerChanghyeok Bae <changhyeok.bae@gmail.com>2018-01-23 22:17:51 +0900
commitfd4ccf8aa32a1ad157851991d9f30eb2b94d59e0 (patch)
tree996527fb5095594cb4dddcc5ff4162dc2995db5e /meta-ivi-common/recipes-test/freetype/freetype_2.8.bbappend
parent62c672ae22635eb3d7ea167ea9955af86d9099fa (diff)
freetype: Rename .bbappend to match new version from meta-openembedded
Bug-AGL: SPEC-1181 Change-Id: I5387a92f2fc0fa988b9df24cf3d13f4eee77c308 Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com>
Diffstat (limited to 'meta-ivi-common/recipes-test/freetype/freetype_2.8.bbappend')
-rw-r--r--meta-ivi-common/recipes-test/freetype/freetype_2.8.bbappend32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-test/freetype/freetype_2.8.bbappend b/meta-ivi-common/recipes-test/freetype/freetype_2.8.bbappend
new file mode 100644
index 000000000..282ce784a
--- /dev/null
+++ b/meta-ivi-common/recipes-test/freetype/freetype_2.8.bbappend
@@ -0,0 +1,32 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI =+ "${SOURCEFORGE_MIRROR}/freetype/ft2demos-${PV}.tar.bz2;name=ft2demos \
+ file://0001-Makefile-dont-build-gfx-demos.patch;patchdir=../ft2demos-${PV} \
+ file://0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch;patchdir=../ft2demos-${PV} \
+ "
+SRC_URI[ft2demos.md5sum] = "61db5831e213acb843f0fc6d10186054"
+SRC_URI[ft2demos.sha256sum] = "2b6ce0d36bcb43fcc8aac07a0287982d855571ee271c3803c768e501f9c1a233"
+
+PACKAGES =+ "${PN}-demos"
+
+B = "${S}"
+
+do_compile_append () {
+
+ oe_runmake -C ${WORKDIR}/ft2demos-${PV} TOP_DIR=${WORKDIR}/${BPN}-${PV}/
+}
+
+do_install_append () {
+ install -d -m 0755 ${D}/${bindir}
+ for x in ftbench ftdump ftlint ftvalid ttdebug; do
+ install -m 0755 ${WORKDIR}/ft2demos-${PV}/bin/.libs/$x ${D}/${bindir}
+ done
+}
+
+FILES_${PN}-demos = "\
+ ${bindir}/ftbench \
+ ${bindir}/ftdump \
+ ${bindir}/ftlint \
+ ${bindir}/ftvalid \
+ ${bindir}/ttdebug \
+"