summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common/recipes-test
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:22:37 +0200
committerGerrit Code Review <gerrit@172.30.200.200>2016-09-01 22:42:01 +0000
commit85844f4d250d1a45129455c76e467e38d3b3e92c (patch)
treeeae6ed37b93870ea9d839834c0bfede384882331 /meta-ivi-common/recipes-test
parentbcd5d1e36b83d39ea57ffa8b271a2256eaed49ff (diff)
Changes for building with YP 2.1.1 'krogoth'
Notable changes: - Update poky-agl.conf for YP 2.1 krogoth - change mesa bbappend to mesa_11 - TODO: check need for gallium, or replace with DRM see SPEC-237 - remote linux-yocto_3.14 as it is no longer shipped with YP 2.1 - rtl-sdr got a fix included for its packageconfig file - update 0001-disable-when-booting-over-nfs.patch - update checksums for ft2demo - TODO: check installation of test binaries - automotive-message-broker needed a workaround in the recipe - TODO: fix package and recipe - wayland-ivi-extension fix for use of autotools _AND_ cmake at the same time: only use cmake - port pulseaudio_6.0.bbappend to pulseaudio_8.0.bbappend - TODO: check patches and forward-port - agl-audio-plugin is currently disabled until ported to pulseaudio 8.0 - gstreamer1.0_1.2.3 is only used by meta-renesas, thus move it there - update dlt-daemon to 2.15 TODO: - check values in poky-agl.conf - check mesa for needed bbappends on other boards (tested qemux86 and qemux86_64) - check pulsaudio bbappend and forward-port patches (patches disabled!) - check agl-audio-plugin and forward-port (build disabled!) - check freetype bbappend wrt. installation path of test binaries - check automotive-message-broker wrt installation routines for libraries (QA failure) - check wayland-ivi-extension build and capabilities Change-Id: I553e03cc37348cba2fc4a022820157c78bb184d3 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-ivi-common/recipes-test')
-rw-r--r--meta-ivi-common/recipes-test/freetype/freetype_%.bbappend8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend b/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
index 94d73aa55..e195dd185 100644
--- a/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
+++ b/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
@@ -3,8 +3,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI =+ "${SOURCEFORGE_MIRROR}/freetype/ft2demos-${PV}.tar.bz2;name=ft2demos \
file://0001-Makefile-dont-build-gfx-demos.patch;patchdir=../ft2demos-${PV} \
"
-SRC_URI[ft2demos.md5sum] = "c6c209b37f10621d6ff100620b8292b4"
-SRC_URI[ft2demos.sha256sum] = "f8f4bc2a2e76e0dbe61838e452c5a7daf1d4bd9dfa44691940bf308f776d32b6"
+SRC_URI[ft2demos.md5sum] = "f7c6102f29834a80456264fe4edd81d1"
+SRC_URI[ft2demos.sha256sum] = "b076ac52465e912d035f111ede78b88bf3dd186f91a56a54ff83ffdf862e84e4"
PACKAGES =+ "${PN}-demos"
@@ -12,14 +12,14 @@ do_compile_append () {
oe_runmake -C ${WORKDIR}/ft2demos-${PV} TOP_DIR=${WORKDIR}/${BPN}-${PV}
}
-do_install_append () {
+do_install_append_checkforkrogoth () {
install -d -m 0755 ${D}/${bindir}
for x in ftbench ftdump ftlint ftvalid ttdebug; do
install -m 0755 ${WORKDIR}/ft2demos-${PV}/bin/$x ${D}/${bindir}
done
}
-FILES_${PN}-demos = "\
+FILES_${PN}-demos_checkforkrogoth = "\
${bindir}/ftbench \
${bindir}/ftdump \
${bindir}/ftlint \