summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-02-10 19:20:25 +0900
committerGerrit Code Review <gerrit@172.30.200.200>2016-03-14 13:33:45 +0000
commit20dfa8d262d6de0c689cce0d8fc0b76a40ba5a75 (patch)
tree9831b16c4072f7bff77fa9bf99340ba34ba22e86 /meta-ivi-common
parentb3a5a720f96df72810b01d2c1d599015924811e0 (diff)
Add package group and bitbake target for Quality Assurance
New packagegroup and bitbake target are added which includes utilities for testing distribution. It is assumed to be used in the Quality Assurance of AGL Distro. New package group: packagegroup-agl-test packagegroup-ivi-common-test New target: agl-image-ivi-qa Change-Id: Ifb20d8a140dd71de6c464499e1b07fd9a0e36457 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'meta-ivi-common')
-rw-r--r--meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb b/meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb
new file mode 100644
index 000000000..e613d43b0
--- /dev/null
+++ b/meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Utilities for testing of AGL"
+DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-ivi-common-test \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "