summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-10-07 00:11:35 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-10-07 20:15:55 +0000
commit1da1fa063421d930c5a882ee28eaba8e88b0449a (patch)
tree94ab3dae02ecccfc4d2c06b73f1f23c73d28ff51 /meta-ivi-common
parenta2dcdc074852955d6c73f56359254cb74ea7faa4 (diff)
Fix freetype recipe to build ft2demos again
This changeset fixes SPEC-261 [1] The recipe relies on ${B} = ${S} and ft2demos needs to find the right libtool. Therefore we remove the hardcoded LIBTOOL in the makefile. LIBTOOL is already set and imported through config.mk v2: replaced sed with patch [1] https://jira.automotivelinux.org/browse/SPEC-261 Change-Id: I25f472a1774b0e7922828271117e96bf254e4b59 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-ivi-common')
-rw-r--r--meta-ivi-common/recipes-test/freetype/files/0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch30
-rw-r--r--meta-ivi-common/recipes-test/freetype/freetype_%.bbappend12
2 files changed, 38 insertions, 4 deletions
diff --git a/meta-ivi-common/recipes-test/freetype/files/0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch b/meta-ivi-common/recipes-test/freetype/files/0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch
new file mode 100644
index 000000000..7803ad7e0
--- /dev/null
+++ b/meta-ivi-common/recipes-test/freetype/files/0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch
@@ -0,0 +1,30 @@
+From 8c4f135619de929f9348b830a07a46a0c2c38e51 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jan-Simon=20M=C3=B6ller?= <jsmoeller@linuxfoundation.org>
+Date: Fri, 7 Oct 2016 15:26:20 +0200
+Subject: [PATCH] Do not hardcode libtool path
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+It is already known and imported through config.mk.
+
+Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
+---
+ Makefile | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index a5d34bd..254aad4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -153,7 +153,6 @@ else
+
+ ifeq ($(PLATFORM),unix)
+ CC = $(CCraw)
+- LIBTOOL = $(OBJ_BUILD)/libtool
+ LINK_CMD = $(subst /,$(SEP),$(LIBTOOL)) \
+ --mode=link $(CC) \
+ $(subst /,$(COMPILER_SEP),$(LDFLAGS))
+--
+2.1.4
+
diff --git a/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend b/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
index e195dd185..926e0d8f0 100644
--- a/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
+++ b/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
@@ -2,24 +2,28 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI =+ "${SOURCEFORGE_MIRROR}/freetype/ft2demos-${PV}.tar.bz2;name=ft2demos \
file://0001-Makefile-dont-build-gfx-demos.patch;patchdir=../ft2demos-${PV} \
+ file://0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch;patchdir=../ft2demos-${PV} \
"
SRC_URI[ft2demos.md5sum] = "f7c6102f29834a80456264fe4edd81d1"
SRC_URI[ft2demos.sha256sum] = "b076ac52465e912d035f111ede78b88bf3dd186f91a56a54ff83ffdf862e84e4"
PACKAGES =+ "${PN}-demos"
+B = "${S}"
+
do_compile_append () {
- oe_runmake -C ${WORKDIR}/ft2demos-${PV} TOP_DIR=${WORKDIR}/${BPN}-${PV}
+
+ oe_runmake -C ${WORKDIR}/ft2demos-${PV} TOP_DIR=${WORKDIR}/${BPN}-${PV}/
}
-do_install_append_checkforkrogoth () {
+do_install_append () {
install -d -m 0755 ${D}/${bindir}
for x in ftbench ftdump ftlint ftvalid ttdebug; do
- install -m 0755 ${WORKDIR}/ft2demos-${PV}/bin/$x ${D}/${bindir}
+ install -m 0755 ${WORKDIR}/ft2demos-${PV}/bin/.libs/$x ${D}/${bindir}
done
}
-FILES_${PN}-demos_checkforkrogoth = "\
+FILES_${PN}-demos = "\
${bindir}/ftbench \
${bindir}/ftdump \
${bindir}/ftlint \