summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common
diff options
context:
space:
mode:
authorYannick Gicquel <yannick.gicquel@iot.bzh>2016-03-31 14:18:33 +0200
committerYannick Gicquel <yannick.gicquel@iot.bzh>2016-03-31 14:18:33 +0200
commit40c365f17dc535b126c4e952b2fd126948b035fb (patch)
treec137c965cbbbc4794c705f48b9dbca31f89f9c28 /meta-ivi-common
parent3656c6b2a718609e0663d78e55a45ec11ccb7c03 (diff)
Add new recipe for Himeno Benchmark
Please refer to http://accc.riken.jp/en/supercom/himenobmt/ for more details on this benchmark. Change-Id: Ia1261940035549086d0c93d61fd5a5d75e83fbcb Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
Diffstat (limited to 'meta-ivi-common')
-rw-r--r--meta-ivi-common/recipes-test/himeno/himeno_2.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-test/himeno/himeno_2.0.bb b/meta-ivi-common/recipes-test/himeno/himeno_2.0.bb
new file mode 100644
index 000000000..56177b9a6
--- /dev/null
+++ b/meta-ivi-common/recipes-test/himeno/himeno_2.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Himeno Benchmark"
+LICENSE = "LGPL-2.0"
+URL = "http://accc.riken.jp/en/supercom/himenobmt/"
+
+SRC_URI = "http://accc.riken.jp/en/wp-content/uploads/sites/2/2015/07/himenobmt.c.zip"
+SRC_URI[md5sum] = "8d8e837dfc3e00a3b322eb4ae3edd551"
+SRC_URI[sha256sum] = "8780bfbdacb0d4dcab2931e65cadd69411731e3f2afcc1231d0743a036298077"
+
+LIC_FILES_CHKSUM = "file://himenoBMT.c;md5=8e8771ddc01c6d1a795e088e2d6dee78"
+
+# Upstream ZIP file contains an LZH archive, thus a 2 steps "unpack" is required.
+# The LZH archive is unpacked after native tools dependency resolution,
+# thus. after "configure" task in our case:
+
+DEPENDS = "p7zip-native"
+
+do_configure_append() {
+ 7z x -y -o${S} ${WORKDIR}/himenobmt.c.lzh
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 bmt ${D}${bindir}
+}