summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common
diff options
context:
space:
mode:
authorNuoHan Qiao <qiaonuohan@cn.fujitsu.com>2016-10-14 16:45:06 +0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-10-19 09:24:30 +0000
commit73a8e595f39fc054e71f0a409d59d5233185eef8 (patch)
tree7d5dea8ec6b16c9e64db85b816b6455c940a6659 /meta-ivi-common
parent23f9990ee5be19162d6622fe64af4c801c732dc2 (diff)
Fix bug of himeno recipe
The Makefile hardcods gcc as compiler, then it will be compiled into wrong format. SO remove it. Change-Id: I3ab4271d26b4e8cdd2b38aa05421a3dde002297c Signed-off-by: NuoHan Qiao <qiaonuohan@cn.fujitsu.com>
Diffstat (limited to 'meta-ivi-common')
-rw-r--r--meta-ivi-common/recipes-test/himeno/himeno_2.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-test/himeno/himeno_2.0.bb b/meta-ivi-common/recipes-test/himeno/himeno_2.0.bb
index 56177b9a6..f890e23a4 100644
--- a/meta-ivi-common/recipes-test/himeno/himeno_2.0.bb
+++ b/meta-ivi-common/recipes-test/himeno/himeno_2.0.bb
@@ -16,6 +16,9 @@ DEPENDS = "p7zip-native"
do_configure_append() {
7z x -y -o${S} ${WORKDIR}/himenobmt.c.lzh
+ cd ${S}
+ sed -i -e 's/CC= gcc/#CC= gcc/' Makefile
+ sed -i -e 's/CFLAGS = /#CFLAGS = /' Makefile
}
do_install () {