summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2016-03-31 18:13:20 +0200
committerGerrit Code Review <gerrit@172.30.200.200>2016-04-04 22:04:42 +0000
commit7a0588cdc35429e3d960bc9d37fe26ea4d28d22f (patch)
tree24de67b43e348c9c1277d3ccb4fe8fec5f18172d /meta-ivi-common
parent40c365f17dc535b126c4e952b2fd126948b035fb (diff)
Add recipe for ebizzy package for QA
Change-Id: Iafcdfc58636eb5b42b6251f46baac96a55e28ed7 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-ivi-common')
-rw-r--r--meta-ivi-common/recipes-test/ebizzy/ebizzy_0.3.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-test/ebizzy/ebizzy_0.3.bb b/meta-ivi-common/recipes-test/ebizzy/ebizzy_0.3.bb
new file mode 100644
index 000000000..19960417b
--- /dev/null
+++ b/meta-ivi-common/recipes-test/ebizzy/ebizzy_0.3.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Benchmark tool that generates a workload resembling common web application server workloads"
+HOMEPAGE = "http://ebizzy.sourceforge.net/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=eb723b61539feef013de476e68b5c50a"
+
+SRC_URI = "http://downloads.sourceforge.net/project/ebizzy/ebizzy/${PV}/ebizzy-${PV}.tar.gz"
+SRC_URI[md5sum] = "af038bc506066bb3d28db08aba62bc38"
+SRC_URI[sha256sum] = "77286029d6348f3d9b3f04eae1feadb5ad1ad07b9f688f4d9f002960862467f2"
+
+do_compile () {
+ ${CC} -Wall -Wshadow -lpthread -o ebizzy ebizzy.c
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ebizzy ${D}${bindir}
+}
+