summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:22:37 +0200
committerGerrit Code Review <gerrit@172.30.200.200>2016-09-01 22:42:01 +0000
commit85844f4d250d1a45129455c76e467e38d3b3e92c (patch)
treeeae6ed37b93870ea9d839834c0bfede384882331 /meta-ivi-common
parentbcd5d1e36b83d39ea57ffa8b271a2256eaed49ff (diff)
Changes for building with YP 2.1.1 'krogoth'
Notable changes: - Update poky-agl.conf for YP 2.1 krogoth - change mesa bbappend to mesa_11 - TODO: check need for gallium, or replace with DRM see SPEC-237 - remote linux-yocto_3.14 as it is no longer shipped with YP 2.1 - rtl-sdr got a fix included for its packageconfig file - update 0001-disable-when-booting-over-nfs.patch - update checksums for ft2demo - TODO: check installation of test binaries - automotive-message-broker needed a workaround in the recipe - TODO: fix package and recipe - wayland-ivi-extension fix for use of autotools _AND_ cmake at the same time: only use cmake - port pulseaudio_6.0.bbappend to pulseaudio_8.0.bbappend - TODO: check patches and forward-port - agl-audio-plugin is currently disabled until ported to pulseaudio 8.0 - gstreamer1.0_1.2.3 is only used by meta-renesas, thus move it there - update dlt-daemon to 2.15 TODO: - check values in poky-agl.conf - check mesa for needed bbappends on other boards (tested qemux86 and qemux86_64) - check pulsaudio bbappend and forward-port patches (patches disabled!) - check agl-audio-plugin and forward-port (build disabled!) - check freetype bbappend wrt. installation path of test binaries - check automotive-message-broker wrt installation routines for libraries (QA failure) - check wayland-ivi-extension build and capabilities Change-Id: I553e03cc37348cba2fc4a022820157c78bb184d3 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-ivi-common')
-rw-r--r--meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb13
-rw-r--r--meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc33
-rw-r--r--meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-multimedia.bb4
-rw-r--r--meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch78
-rw-r--r--meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch25
-rw-r--r--meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon_2.15.0.bb42
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bb3
-rw-r--r--meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav/0001-Disable-yasm-for-libav-when-disable-yasm.patch33
-rw-r--r--meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.2.3.bb26
-rw-r--r--meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.0.0.bb13
-rw-r--r--meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend2
-rw-r--r--meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.2.3.bb11
-rw-r--r--meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.3.bb11
-rw-r--r--meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.2.3.bb10
-rw-r--r--meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.2.3.bb9
-rw-r--r--meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0/0001-Fix-crash-with-gst-inspect.patch28
-rw-r--r--meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0_1.2.3.bb14
-rw-r--r--meta-ivi-common/recipes-multimedia/pulseaudio/pulseaudio_8.0.bbappend (renamed from meta-ivi-common/recipes-multimedia/pulseaudio/pulseaudio_6.0.bbappend)5
-rw-r--r--meta-ivi-common/recipes-test/freetype/freetype_%.bbappend8
19 files changed, 133 insertions, 235 deletions
diff --git a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
index dee6f5980..fb1cb774f 100644
--- a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
+++ b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
@@ -38,6 +38,19 @@ do_install_append() {
if [ "${@bb.utils.contains('PACKAGECONFIG', 'use_gps', 'use_gps', '', d)}" = "use_gps" ]; then
install -m 0644 ${WORKDIR}/gps ${D}/${sysconfdir}/ambd/plugins.d
fi
+
+ # Grmbl - heck gotta fix library installations ?!? WTF !
+ # GO FIX YOUR INSTALLATION ROUTINES PLEASE. ;) (jsmoeller)
+ # HACK-ALARM:
+ ls -alh ${D}${libdir}
+ if test -e ${D}${libdir}/libamb-qt.so -a ! -L ${D}${libdir}/libamb-qt.so ; then
+ mv ${D}${libdir}/libamb-qt.so ${D}${libdir}/libamb-qt.so.0
+ ln -sf libamb-qt.so.0 ${D}${libdir}/libamb-qt.so
+ fi
+ if test -e ${D}${libdir}/libamb-plugins-common.so -a ! -L ${D}${libdir}/libamb-plugins-common.so ; then
+ mv ${D}${libdir}/libamb-plugins-common.so ${D}${libdir}/libamb-plugins-common.so.0
+ ln -sf libamb-plugins-common.so.0 ${D}${libdir}/libamb-plugins-common.so
+ fi
}
FILES_${PN} += " ${systemd_unitdir}/ambd.service \
diff --git a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc
index 377e9ebc1..88adfab49 100644
--- a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc
+++ b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.inc
@@ -1,8 +1,12 @@
LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=b42382de5d854b9bb598acf2e8827de3"
-SRC_URI = "git://github.com/CogentEmbedded/automotive-message-broker.git;protocol=https;branch=master"
-SRCREV = "58569fac42bb8b6e1ad208caef5db8a51befc87f"
+#SRC_URI = "git://github.com/CogentEmbedded/automotive-message-broker.git;protocol=https;branch=master"
+#SRCREV = "58569fac42bb8b6e1ad208caef5db8a51befc87f"
+
+SRC_URI = "git://github.com/otcshare/automotive-message-broker.git;branch=0.14"
+SRCREV = "c216955d16ca275159891cad296217094d972390"
+#SRCREV = "c26819073d2a1444a156e4d2e3b61bef81663ea5"
PV = "0.14+git${SRCPV}"
@@ -10,18 +14,23 @@ PV = "0.14+git${SRCPV}"
# hash:58569fac42bb8b6e1ad208caef5db8a51befc87f(main branch) and
# hash:8f761e02172544212915c82b7e8dd8d4dd1281a6(dev_0.14_2)
SRC_URI += " \
- file://0001-Improve-backward-compatibility-with-old-linaro-gcc.patch \
- file://0002-Fix-library-versioning.patch \
- file://0003-AmbSignalMapper-fix-can-interface-specification.patch \
- file://0004-cansocketbcm-Fix-reading-of-frames-in-case-of-RX_TIM.patch \
- file://0005-ambctl-remove-unnecessary-dependency-on-glib-introsp.patch \
- file://0006-cangen-Implement-basic-handling-of-RX_TIMEOUT.patch \
- file://0007-WORKAROUND-Allow-amb-qt-binding-to-work-in-case-of-m.patch \
- file://0008-Add-simple-Qt-QML-example.patch \
- file://0009-Add-Pressure-property-to-BrakeOperation.patch \
- file://0001-Fix-build-issues-while-bitbake-without-meta-qt5-laye.patch \
file://ambd.service \
file://gps \
"
+# file://0001-Improve-backward-compatibility-with-old-linaro-gcc.patch
+# file://0002-Fix-library-versioning.patch
+# file://0003-AmbSignalMapper-fix-can-interface-specification.patch
+# file://0004-cansocketbcm-Fix-reading-of-frames-in-case-of-RX_TIM.patch
+# file://0005-ambctl-remove-unnecessary-dependency-on-glib-introsp.patch
+# file://0006-cangen-Implement-basic-handling-of-RX_TIMEOUT.patch
+# file://0007-WORKAROUND-Allow-amb-qt-binding-to-work-in-case-of-m.patch
+# file://0008-Add-simple-Qt-QML-example.patch
+# file://0009-Add-Pressure-property-to-BrakeOperation.patch
+# file://0001-Fix-build-issues-while-bitbake-without-meta-qt5-laye.patch
S = "${WORKDIR}/git"
+
+INSANE_SKIP_{PN} += "dev-elf"
+INSANE_SKIP_{PN} += "dev-deps"
+INSANE_SKIP_{PN}-devel += "dev-elf"
+INSANE_SKIP_{PN}-devel += "dev-deps"
diff --git a/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-multimedia.bb b/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-multimedia.bb
index 75e496290..41b50e6a6 100644
--- a/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-multimedia.bb
+++ b/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-multimedia.bb
@@ -16,6 +16,8 @@ RDEPENDS_${PN} += "\
alsa-utils \
pulseaudio-server \
pulseaudio-misc \
- agl-audio-plugin \
gstreamer1.0-meta-base \
"
+RDEPENDS_${PN}_checkforkrogoth += "\
+ agl-audio-plugin \
+"
diff --git a/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch
index 40c5afbeb..168847990 100644
--- a/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch
+++ b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0002-Don-t-execute-processes-as-a-specific-user.patch
@@ -7,85 +7,75 @@ Upstream-Status: Inappropriate [Configuration Specific]
Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
---
systemd/dlt-adaptor-udp.service.cmake | 1 -
- systemd/dlt-dbus.service.cmake | 1 -
systemd/dlt-example-user.service.cmake | 1 -
systemd/dlt-receive.service.cmake | 1 -
systemd/dlt-system.service.cmake | 1 -
systemd/dlt.service.cmake | 1 -
- 6 files changed, 6 deletions(-)
+ 5 files changed, 5 deletions(-)
diff --git a/systemd/dlt-adaptor-udp.service.cmake b/systemd/dlt-adaptor-udp.service.cmake
-index 0c39637..f446757 100644
+index 8dac1f2..ecf9f9e 100644
--- a/systemd/dlt-adaptor-udp.service.cmake
+++ b/systemd/dlt-adaptor-udp.service.cmake
-@@ -20,7 +20,6 @@ Wants=dlt.service
+@@ -21,9 +21,8 @@ Wants=dlt.service
[Service]
- Type=Simple
--User=genivi
+ Type=simple
+-User=@DLT_USER@
ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-adaptor-udp -a @DLT_ADAPTOR_UDP_APPID@ -c @DLT_ADAPTOR_UDP_CTID@ -p @DLT_ADAPTOR_UDP_PORT@
LimitCORE=infinity
-diff --git a/systemd/dlt-dbus.service.cmake b/systemd/dlt-dbus.service.cmake
-index 2727c2d..d1e3b12 100755
---- a/systemd/dlt-dbus.service.cmake
-+++ b/systemd/dlt-dbus.service.cmake
-@@ -21,7 +21,6 @@ Wants=dlt.service
-
- [Service]
- Type=Simple
--User=root
- ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-dbus
- WatchdogSec=@DLT_WatchdogSec@
- NotifyAccess=main
+ [Install]
+-WantedBy=multi-user.target
+\ No newline at end of file
++WantedBy=multi-user.target
diff --git a/systemd/dlt-example-user.service.cmake b/systemd/dlt-example-user.service.cmake
-index 3652292..b67a83c 100644
+index b665742..35009b0 100644
--- a/systemd/dlt-example-user.service.cmake
+++ b/systemd/dlt-example-user.service.cmake
-@@ -20,6 +20,5 @@ Wants=dlt.service
+@@ -21,6 +21,5 @@ Wants=dlt.service
[Service]
- Type=Simple
--User=genivi
+ Type=simple
+-User=@DLT_USER@
ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-example-user "Hallo from GENIVI DLT example user application"
- LimitCORE=infinity
+-LimitCORE=infinity
\ No newline at end of file
++LimitCORE=infinity
diff --git a/systemd/dlt-receive.service.cmake b/systemd/dlt-receive.service.cmake
-index b92c8b2..4bbdfc2 100644
+index c07d447..8f88f00 100644
--- a/systemd/dlt-receive.service.cmake
+++ b/systemd/dlt-receive.service.cmake
-@@ -21,6 +21,5 @@ Wants=dlt.service
+@@ -22,6 +22,5 @@ Wants=dlt.service
[Service]
- Type=Simple
--User=genivi
+ Type=simple
+-User=@DLT_USER@
ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-receive -o /tmp/dlt_receive_log.dlt localhost
- LimitCORE=infinity
+-LimitCORE=infinity
\ No newline at end of file
++LimitCORE=infinity
diff --git a/systemd/dlt-system.service.cmake b/systemd/dlt-system.service.cmake
-index f5e844b..7ec995c 100755
+index 0e91f42..1a5b913 100755
--- a/systemd/dlt-system.service.cmake
+++ b/systemd/dlt-system.service.cmake
-@@ -21,7 +21,6 @@ Wants=dlt.service
-
- [Service]
- Type=Simple
--User=genivi
- ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-system
- WatchdogSec=@DLT_WatchdogSec@
- NotifyAccess=main
+@@ -22,7 +22,6 @@ Wants=dlt.service
+
+ [Service]
+ Type=simple
+-User=@DLT_USER@
+ ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-system
+ WatchdogSec=@DLT_WatchdogSec@
+ NotifyAccess=main
diff --git a/systemd/dlt.service.cmake b/systemd/dlt.service.cmake
-index 22279c4..7bb05bc 100755
+index 0b3ee2c..e4753a2 100755
--- a/systemd/dlt.service.cmake
+++ b/systemd/dlt.service.cmake
-@@ -20,7 +20,6 @@ Documentation=man:dlt-daemon(1) man:dlt.conf(5)
+@@ -21,7 +21,6 @@ Documentation=man:dlt-daemon(1) man:dlt.conf(5)
[Service]
- Type=Simple
--User=genivi
+ Type=simple
+-User=@DLT_USER@
ExecStart=@CMAKE_INSTALL_PREFIX@/bin/dlt-daemon
WatchdogSec=@DLT_WatchdogSec@
NotifyAccess=main
---
-1.9.3
-
diff --git a/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
index df762f33d..685dfcddc 100644
--- a/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
+++ b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon/0004-Modify-systemd-config-directory.patch
@@ -9,19 +9,16 @@ Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
systemd/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/systemd/CMakeLists.txt b/systemd/CMakeLists.txt
-index a9838e4..c8feae5 100644
---- a/systemd/CMakeLists.txt
-+++ b/systemd/CMakeLists.txt
-@@ -16,7 +16,7 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e6b44a2..0e885bf 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -175,7 +175,7 @@ if(WITH_SYSTEMD OR WITH_SYSTEMD_WATCHDOG OR WITH_SYSTEMD_JOURNAL)
- if(WITH_SYSTEMD)
+ set( systemd_SRCS ${CMAKE_SOURCE_DIR}/systemd/3rdparty/sd-daemon.c)
-- set(SYSTEMD_CONFIGURATIONS_FILES_DIR ${CMAKE_INSTALL_PREFIX}/lib/systemd/system )
-+ set(SYSTEMD_CONFIGURATIONS_FILES_DIR /lib/systemd/system )
-
- if(WITH_SYSTEMD_WATCHDOG)
- set( DLT_WatchdogSec 2 )
---
-1.9.3
-
+- set(SYSTEMD_UNITDIR "${CMAKE_INSTALL_PREFIX}/lib/systemd/system" CACHE PATH
++ set(SYSTEMD_UNITDIR "/lib/systemd/system" CACHE PATH
+ "Set directory to install systemd unit files")
+
+ add_subdirectory( systemd )
diff --git a/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon_2.15.0.bb b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon_2.15.0.bb
new file mode 100644
index 000000000..8ab95d1ec
--- /dev/null
+++ b/meta-ivi-common/recipes-extended/dlt-daemon/dlt-daemon_2.15.0.bb
@@ -0,0 +1,42 @@
+SUMMARY = "Diagnostic Log and Trace"
+DESCRIPTION = "This component provides a standardised log and trace interface, \
+based on the standardised protocol specified in the AUTOSAR standard 4.0 DLT. \
+This component can be used by GENIVI components and other applications as \
+logging facility providing: \
+- the DLT shared library \
+- the DLT daemon, including startup scripts \
+- the DLT daemon adaptors- the DLT client console utilities \
+- the DLT test applications"
+HOMEPAGE = "https://www.genivi.org/"
+SECTION = "console/utils"
+LICENSE = "MPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8184208060df880fe3137b93eb88aeea"
+
+DEPENDS = "dbus zlib"
+
+SRCREV = "e9a486a08fff6d3cc7133a350cec3ee10f463207"
+SRC_URI = "git://git.projects.genivi.org/${BPN}.git;protocol=http \
+ file://0002-Don-t-execute-processes-as-a-specific-user.patch \
+ file://0004-Modify-systemd-config-directory.patch \
+ "
+S = "${WORKDIR}/git"
+
+inherit gzipnative autotools gettext cmake systemd
+
+PACKAGES += "${PN}-systemd"
+SYSTEMD_PACKAGES = "${PN} ${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "dlt-system.service dlt.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "enable"
+SYSTEMD_SERVICE_${PN}-systemd = "dlt-example-user.service \
+ dlt-dbus.service \
+ dlt-adaptor-udp.service \
+ dlt-receive.service"
+SYSTEMD_AUTO_ENABLE_${PN}-systemd = "disable"
+
+EXTRA_OECMAKE = "-DWITH_SYSTEMD=ON"
+
+FILES_${PN}-doc += "/usr/share/dlt-filetransfer"
+
+do_install_append() {
+ rm -f ${D}${bindir}/dlt-test-*
+}
diff --git a/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bb b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bb
index d674be8b3..9ea7d24bb 100644
--- a/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bb
+++ b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bb
@@ -15,7 +15,8 @@ SRCREV = "44598504503eea5ac7f94c88477a5a78bda01f30"
S = "${WORKDIR}/git"
-inherit cmake autotools
+inherit cmake
+#jsmoeller: rm autotools from inherit ... there can only be one
PACKAGECONFIG ??= "ilm_input"
PACKAGECONFIG[ivi-share] = "-DIVI_SHARE=ON,-DIVI_SHARE=OFF,libgbm libdrm"
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav/0001-Disable-yasm-for-libav-when-disable-yasm.patch b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav/0001-Disable-yasm-for-libav-when-disable-yasm.patch
deleted file mode 100644
index 1d99ad125..000000000
--- a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav/0001-Disable-yasm-for-libav-when-disable-yasm.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 54bba228ea52d01fd84941d97be23c03f9862b64 Mon Sep 17 00:00:00 2001
-From: Carlos Rafael Giani <dv@pseudoterminal.org>
-Date: Sat, 6 Apr 2013 01:22:22 +0200
-Subject: [PATCH] Disable yasm for libav when --disable-yasm
-
-Upstream-Status: Inappropriate [configuration]
-
-Signed-off-by: Shane Wang <shane.wang@intel.com>
-Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
----
- configure.ac | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index 22ede88..ef3c050 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -305,6 +305,12 @@ else
- emblibav_configure_args="$emblibav_configure_args --enable-gpl"
- fi
-
-+ AC_ARG_ENABLE(yasm,
-+ [AC_HELP_STRING([--disable-yasm], [disable use of yasm assembler])])
-+ if test "x$enable_yasm" = "xno"; then
-+ emblibav_configure_args="$emblibav_configure_args --disable-yasm"
-+ fi
-+
- # if we are cross-compiling, tell libav so
- case $host in
- *android*)
---
-1.8.2
-
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.2.3.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.2.3.bb
deleted file mode 100644
index 2e6ed2e55..000000000
--- a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.2.3.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-DEFAULT_PREFERENCE = "-1"
-
-include recipes-multimedia/gstreamer/gstreamer1.0-libav.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
- file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
- file://ext/libav/gstav.h;beginline=1;endline=18;md5=a752c35267d8276fd9ca3db6994fca9c \
- file://gst-libs/ext/libav/LICENSE;md5=23a54f59b82572c203a559346e89ed57 \
- file://gst-libs/ext/libav/COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
- file://gst-libs/ext/libav/COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
- file://gst-libs/ext/libav/COPYING.LGPLv2.1;md5=bd7a443320af8c812e4c18d1b79df004 \
- file://gst-libs/ext/libav/COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02"
-
-SRC_URI = " \
- http://gstreamer.freedesktop.org/src/gst-libav/gst-libav-${PV}.tar.xz \
- file://0001-Disable-yasm-for-libav-when-disable-yasm.patch \
- "
-SRC_URI[md5sum] = "58c7998a054d8d8ca041fa35738f72b6"
-SRC_URI[sha256sum] = "ebc7fbe10955f40df6ccc4bf689075e7e296205fc7ecd8ff383d43c5cdf5bcd6"
-LIBAV_EXTRA_CONFIGURE_COMMON_ARG = "--target-os=linux \
- --cc='${CC}' --as='${CC}' --ld='${CC}' --nm='${NM}' --ar='${AR}' \
- --ranlib='${RANLIB}' \
- ${GSTREAMER_1_0_DEBUG}"
-
-S = "${WORKDIR}/gst-libav-${PV}"
-
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.0.0.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.0.0.bb
deleted file mode 100644
index 0903f1295..000000000
--- a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.0.0.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-DEFAULT_PREFERENCE = "-1"
-
-include recipes-multimedia/gstreamer/gstreamer1.0-omx.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
- file://omx/gstomx.h;beginline=1;endline=21;md5=5c8e1fca32704488e76d2ba9ddfa935f"
-
-SRC_URI = "http://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz"
-
-SRC_URI[md5sum] = "bb34b5742223267298bcffc209104a92"
-SRC_URI[sha256sum] = "7a1d8d28d70dacc6bd3c7ee7d7e40df6d5a1d38d7c256d5c9c5c8ef15c005014"
-
-S = "${WORKDIR}/gst-omx-${PV}"
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
deleted file mode 100644
index e22e3f808..000000000
--- a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-PACKAGECONFIG[bluez] = "--enable-bluez,--disable-bluez,bluez5"
-
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.2.3.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.2.3.bb
deleted file mode 100644
index 29b8d5188..000000000
--- a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.2.3.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-DEFAULT_PREFERENCE = "-1"
-
-include recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=73a5855a8119deb017f5f13cf327095d \
- file://gst/tta/filters.h;beginline=12;endline=29;md5=8a08270656f2f8ad7bb3655b83138e5a \
- file://COPYING.LIB;md5=21682e4e8fea52413fd26c60acb907e5 \
- file://gst/tta/crc32.h;beginline=12;endline=29;md5=27db269c575d1e5317fffca2d33b3b50"
-SRC_URI[md5sum] = "cfd6f303c8df2740b27cc63b945decef"
-SRC_URI[sha256sum] = "595d7911a9e6207dea37200587724bdbf841b81a5eb0730118be36976684278c"
-S = "${WORKDIR}/gst-plugins-bad-${PV}"
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.3.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.3.bb
deleted file mode 100644
index aa7c44850..000000000
--- a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.3.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-DEFAULT_PREFERENCE = "-1"
-
-include recipes-multimedia/gstreamer/gstreamer1.0-plugins-base.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=c54ce9345727175ff66d17b67ff51f58 \
- file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
- file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
- "
-SRC_URI[md5sum] = "17aeabfbcd232526f50c9bee375f1b97"
-SRC_URI[sha256sum] = "61edec35c270f86928bad434bd059da4efff865d1ef01bcc64ecbd903625dae1"
-S = "${WORKDIR}/gst-plugins-base-${PV}"
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.2.3.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.2.3.bb
deleted file mode 100644
index 4c01d2864..000000000
--- a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.2.3.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-DEFAULT_PREFERENCE = "-1"
-
-include recipes-multimedia/gstreamer/gstreamer1.0-plugins-good.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
- file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
- file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
-SRC_URI[md5sum] = "1a1f96bc27ad446e559474299160a9a8"
-SRC_URI[sha256sum] = "bfb33536a515bdcc34482f64b8d9cc3e47c753878b254923b419bc2f7485e470"
-S = "${WORKDIR}/gst-plugins-good-${PV}"
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.2.3.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.2.3.bb
deleted file mode 100644
index 0ac772158..000000000
--- a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.2.3.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-DEFAULT_PREFERENCE = "-1"
-
-include recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
- file://tests/check/elements/xingmux.c;beginline=1;endline=21;md5=4c771b8af188724855cb99cadd390068 "
-SRC_URI[md5sum] = "7ae60e2f759f58f32af5fcdc3c9193c4"
-SRC_URI[sha256sum] = "537b0a7607eee499026388bb705b5b68985a3fd59fe22ee09accaf8cdf57eb3b"
-S = "${WORKDIR}/gst-plugins-ugly-${PV}"
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0/0001-Fix-crash-with-gst-inspect.patch b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0/0001-Fix-crash-with-gst-inspect.patch
deleted file mode 100644
index 94f5cc56e..000000000
--- a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0/0001-Fix-crash-with-gst-inspect.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 6b26f3dbf9bf577d71534ab7410de66d06e46ba2 Mon Sep 17 00:00:00 2001
-From: Carlos Rafael Giani <dv@pseudoterminal.org>
-Date: Sat, 6 Apr 2013 23:52:11 +0200
-Subject: [PATCH] Fix crash with gst-inspect Chris Lord <chris@openedhand.com>
-
-Upstream-Status: Pending
-
-Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
----
- tools/gst-inspect.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tools/gst-inspect.c b/tools/gst-inspect.c
-index 23b7c44..b79b02e 100644
---- a/tools/gst-inspect.c
-+++ b/tools/gst-inspect.c
-@@ -1556,7 +1556,7 @@ main (int argc, char *argv[])
- g_option_context_add_main_entries (ctx, options, GETTEXT_PACKAGE);
- g_option_context_add_group (ctx, gst_init_get_option_group ());
- if (!g_option_context_parse (ctx, &argc, &argv, &err)) {
-- g_printerr ("Error initializing: %s\n", err->message);
-+ g_printerr ("Error initializing: %s\n", err ? err->message : "(null)");
- return -1;
- }
- g_option_context_free (ctx);
---
-1.8.2
-
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0_1.2.3.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0_1.2.3.bb
deleted file mode 100644
index caacc3435..000000000
--- a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0_1.2.3.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-DEFAULT_PREFERENCE = "-1"
-
-include recipes-multimedia/gstreamer/gstreamer1.0.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
- file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
-
-SRC_URI = " \
- http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
- file://0001-Fix-crash-with-gst-inspect.patch \
- "
-SRC_URI[md5sum] = "8155b9c7574ccaa361cc504e8e0e72dc"
-SRC_URI[sha256sum] = "0f9a9817a384b3448c368c23345e5122435caef9c00f1c40d7b1953827b0d8eb"
-S = "${WORKDIR}/gstreamer-${PV}"
diff --git a/meta-ivi-common/recipes-multimedia/pulseaudio/pulseaudio_6.0.bbappend b/meta-ivi-common/recipes-multimedia/pulseaudio/pulseaudio_8.0.bbappend
index 7b1ffbe0e..f7223e3e6 100644
--- a/meta-ivi-common/recipes-multimedia/pulseaudio/pulseaudio_6.0.bbappend
+++ b/meta-ivi-common/recipes-multimedia/pulseaudio/pulseaudio_8.0.bbappend
@@ -1,7 +1,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/pulseaudio:"
-SRC_URI += " \
- file://0008-install-files-for-a-module-development.patch \
+SRC_URI += " file://0008-install-files-for-a-module-development.patch"
+
+SRC_URI_needtocheckforkrogoth += " \
file://0010-volume-ramp-additions-to-the-low-level-infra.patch \
file://0011-volume-ramp-adding-volume-ramping-to-sink-input.patch \
file://0012-volume-ramp-add-volume-ramping-to-sink.patch \
diff --git a/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend b/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
index 94d73aa55..e195dd185 100644
--- a/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
+++ b/meta-ivi-common/recipes-test/freetype/freetype_%.bbappend
@@ -3,8 +3,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI =+ "${SOURCEFORGE_MIRROR}/freetype/ft2demos-${PV}.tar.bz2;name=ft2demos \
file://0001-Makefile-dont-build-gfx-demos.patch;patchdir=../ft2demos-${PV} \
"
-SRC_URI[ft2demos.md5sum] = "c6c209b37f10621d6ff100620b8292b4"
-SRC_URI[ft2demos.sha256sum] = "f8f4bc2a2e76e0dbe61838e452c5a7daf1d4bd9dfa44691940bf308f776d32b6"
+SRC_URI[ft2demos.md5sum] = "f7c6102f29834a80456264fe4edd81d1"
+SRC_URI[ft2demos.sha256sum] = "b076ac52465e912d035f111ede78b88bf3dd186f91a56a54ff83ffdf862e84e4"
PACKAGES =+ "${PN}-demos"
@@ -12,14 +12,14 @@ do_compile_append () {
oe_runmake -C ${WORKDIR}/ft2demos-${PV} TOP_DIR=${WORKDIR}/${BPN}-${PV}
}
-do_install_append () {
+do_install_append_checkforkrogoth () {
install -d -m 0755 ${D}/${bindir}
for x in ftbench ftdump ftlint ftvalid ttdebug; do
install -m 0755 ${WORKDIR}/ft2demos-${PV}/bin/$x ${D}/${bindir}
done
}
-FILES_${PN}-demos = "\
+FILES_${PN}-demos_checkforkrogoth = "\
${bindir}/ftbench \
${bindir}/ftdump \
${bindir}/ftlint \