aboutsummaryrefslogtreecommitdiffstats
path: root/meta-netboot/recipes-core
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-06-28 15:44:34 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-06-28 20:02:11 +0000
commit84a229c05b5ff760fe64f74cb3c4f71e6c5b8188 (patch)
treec5b39d9826b6ee684bc3c081e8a63c7506fad763 /meta-netboot/recipes-core
parentdb2fae4724880a43e5942bf770bc8e6e200012b4 (diff)
Fix rpi-sdimg after IMAGE_FSTYPE being enforced in poky-agl.conf
This changeset fixes the case of the rpi-sdimg which was broken by the IMAGE_FSTYPE setting introduced in poky-agl.conf (distro-wide). A new variable AGL_EXTRA_IMAGE_FSTYPES is available now and only used in AGL (target) images. Reasoning for this solution: - any modifications to IMAGE_FSTYPES will also affect things like the initramfs or initrd images. - we minimized the disk-space requirements by reusing the ext4.xz for the rpi-sdimg Bug-AGL: SPEC-492 Change-Id: I07fd51dbcf334653cd6033b7ccb663c4d4ed8578 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9887 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Diffstat (limited to 'meta-netboot/recipes-core')
-rw-r--r--meta-netboot/recipes-core/images/initramfs-netboot-image.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-netboot/recipes-core/images/initramfs-netboot-image.bb b/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
index b9c8d2f75..cc6bc6753 100644
--- a/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
+++ b/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
@@ -11,7 +11,7 @@ IMAGE_LINGUAS = ""
LICENSE = "MIT"
-IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+IMAGE_FSTYPES = "${NETBOOT_FSTYPES}"
inherit core-image
IMAGE_ROOTFS_SIZE = "8192"