summaryrefslogtreecommitdiffstats
path: root/meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.47.bbappend
diff options
context:
space:
mode:
authorAshok Sidipotu <ashok.sidipotu@collabora.com>2022-02-24 11:46:15 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-03-05 19:16:04 +0000
commitdebe203be9bf5e842b082751f53cb0502be02db1 (patch)
tree6303438434b673d9ea80608e6eee6f3072b576e2 /meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.47.bbappend
parent76af8fd0941168ca3bbd1cf3b7c283a87c382281 (diff)
pipewire: Update pw to v0.3.47 and wp to v0.4.8
Highlights of Pipewire. - Removed check and warnings to catch leaked listeners on the proxy. - Fix critical bug where alsa devices would not show when the kernel was compiled without VERBOSE_PROCFS - Almost all limits on number of ports, clients and nodes are removed. - Many more bug fixes and imporovements. Highlights of Wireplumber. - Added bluetooth profile auto-switching support between A2DP and HFP modes - Better default audio sources and sinks selection - Backported a fix for a known issue with selecting the default devices on top of 0.4.8 (ae6c9a5e) - Many more bug fixes and imporovements. Change-Id: Id5414aed065593893a237437a8c77645cbf15804 Signed-off-by: Ashok Sidipotu <ashok.sidipotu@collabora.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27220 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.47.bbappend')
-rw-r--r--meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.47.bbappend36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.47.bbappend b/meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.47.bbappend
new file mode 100644
index 000000000..8c8467b52
--- /dev/null
+++ b/meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.47.bbappend
@@ -0,0 +1,36 @@
+PACKAGECONFIG = "\
+ ${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa pipewire-alsa', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'sndfile', '', d)} \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
+ gstreamer v4l2 \
+"
+
+SRC_URI += "\
+ file://0001-Revert-treewide-meson.build-use-project_-build-sourc.patch \
+ file://0002-Revert-treewide-meson.build-use-feature.allowed.patch \
+ file://0003-Revert-treewide-meson.build-use-dependency-variable-.patch \
+ file://0004-Revert-treewide-meson.build-simplify-get_variable-ca.patch \
+ file://0005-Revert-treewide-meson.build-get-SPA_PLUGIN_DIR-from-.patch \
+ file://0006-Revert-meson-declare-spa_dep-and-override_dependency.patch \
+ file://0007-Revert-meson-use-meson-variables-for-the-SMs-uninsta.patch \
+ file://0008-Revert-meson-declare-spa_dep-and-override_dependency.patch \
+ file://0009-Revert-test-add-test-for-the-loop.patch \
+ file://0010-Revert-spa-improve-the-AEC-interface.patch \
+ file://0011-Revert-module-echo-cancel-Move-backends-to-dynamic-l.patch \
+ file://0012-Miscellanous-changes-to-account-for-lower-version-of.patch \
+"
+
+do_install:append() {
+ # install symlinks to alsalib configuration files
+ for i in 50-pipewire.conf 99-pipewire-default.conf; do
+ if [ -f ${D}${datadir}/alsa/alsa.conf.d/${i} ]; then
+ mkdir -p ${D}${sysconfdir}/alsa/conf.d
+ ln -s ${datadir}/alsa/alsa.conf.d/${i} ${D}${sysconfdir}/alsa/conf.d/${i}
+ fi
+ done
+}
+
+FILES:${PN}-alsa:append = "\
+ ${sysconfdir}/alsa/conf.d/* \
+"