summaryrefslogtreecommitdiffstats
path: root/meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.83.bbappend
diff options
context:
space:
mode:
authorAshok Sidipotu <ashok.sidipotu@collabora.com>2023-10-27 15:55:01 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-07 21:42:45 +0000
commit762c46e7456563c2f10a9054195a89599fd0e24c (patch)
treee5f6c60cb71b225232d372d59c5c71429df4ed8a /meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.83.bbappend
parent668f28b41566f9666e8e7f75ba7193d095d13929 (diff)
pipewire: Update PipeWire to v0.3.83 and WirePlumber to v0.4.15
Highlights of Pipewire. - Add BAP broadcast source and sink support. - Vulkan DMA buf support was merged. - Fix a leak in the SBC codecs for SCO. - More bugfixes and improvements. - IRQ based scheduling in ALSA was improved and enabled by default for Pro-Audio profile. It will also link the pcms together to get lower latency. This now matches what JACK does and results in equal latency for Pro-Audio profiles. - A new L permission was added to make it possible to force a link between nodes even when the nodes can't see each other. - Libcamera and v4l2 devices now have properties so that duplicates can be filtered out by the session manager. - Improve RAOP compatibility. - ALSA hires timestamps are now disabled by default. Highlights of Wireplumber. - A new "DSP policy" module has been added; its purpose is to automatically load a filter-chain when a certain hardware device is present, so that audio always goes through this software DSP before reaching the device. This is mainly to support Apple M1/M2 devices, which require a software DSP to be always present - WpImplModule now supports loading module arguments directly from a SPA-JSON config file; this is mainly to support DSP configuration for Apple M1/M2 and will likely be reworked for 0.5 Bug-AGL: SPEC-4940 Change-Id: I7caa7b08686704cc94be896bcd0c2269ab3c8133 Signed-off-by: Ashok Sidipotu <ashok.sidipotu@collabora.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29388 Tested-by: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-boot-test: Jenkins Job builder account ci-image-build: Jenkins Job builder account
Diffstat (limited to 'meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.83.bbappend')
-rw-r--r--meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.83.bbappend25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.83.bbappend b/meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.83.bbappend
new file mode 100644
index 000000000..beb7c0817
--- /dev/null
+++ b/meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.83.bbappend
@@ -0,0 +1,25 @@
+SRC_URI += "\
+ file://0001-systemd-Do-not-override-rootprefix.patch \
+"
+
+PACKAGECONFIG = "\
+ ${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa pipewire-alsa', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'sndfile', '', d)} \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
+ gstreamer v4l2 \
+"
+
+do_install:append() {
+ # install symlinks to alsalib configuration files
+ for i in 50-pipewire.conf 99-pipewire-default.conf; do
+ if [ -f ${D}${datadir}/alsa/alsa.conf.d/${i} ]; then
+ install -d ${D}${sysconfdir}/alsa/conf.d
+ ln -s ${datadir}/alsa/alsa.conf.d/${i} ${D}${sysconfdir}/alsa/conf.d/${i}
+ fi
+ done
+}
+
+FILES:${PN}-alsa:append = "\
+ ${sysconfdir}/alsa/conf.d/* \
+"