summaryrefslogtreecommitdiffstats
path: root/meta-pipewire/recipes-multimedia/wireplumber/wireplumber_%.bbappend
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2024-12-13 12:03:52 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-12-16 13:44:26 +0000
commit3454e7628adac4d83f7a5058e4dd1bb9a716baa5 (patch)
treeebbf6696994b7cc87f019b76cd230250ce8405a7 /meta-pipewire/recipes-multimedia/wireplumber/wireplumber_%.bbappend
parent2e060732691ed8fcee6725cf8ebc92e887bfd188 (diff)
wireplumber: fix audio randomly not working at boot time
This issue is caused by a race condition that triggers some links to be created and then destroyed very fast, but at a certain point where the managing object (si-standard-link) is not fully configured yet. At that point, droping the ref count of the si-standard-link doesn't destroy it and the links remain dangling, causing a loop in the graph that prevents audio from working properly. This patch mitigates the issue by forcing si-standard-link to reset to its initial state, forcing the pipewire links to be destroyed. This does not, however, prevent the potential leak of the si-standard-link. A better solution is being worked on for upstreaming. Bug-AGL: SPEC-5244 Change-Id: I61477c0c021351903239d58fff0217e25e08db02 Signed-off-by: George Kiagiadakis <george.kiagiadakis@collabora.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/30653 ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-pipewire/recipes-multimedia/wireplumber/wireplumber_%.bbappend')
-rw-r--r--meta-pipewire/recipes-multimedia/wireplumber/wireplumber_%.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-pipewire/recipes-multimedia/wireplumber/wireplumber_%.bbappend b/meta-pipewire/recipes-multimedia/wireplumber/wireplumber_%.bbappend
index 16d3817cd..bf71dc3c3 100644
--- a/meta-pipewire/recipes-multimedia/wireplumber/wireplumber_%.bbappend
+++ b/meta-pipewire/recipes-multimedia/wireplumber/wireplumber_%.bbappend
@@ -1,3 +1,9 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " \
+ file://0001-linking-reset-link-when-moving-target.patch \
+"
+
do_install:append() {
systemd_dir="${D}${sysconfdir}/systemd/system/"