aboutsummaryrefslogtreecommitdiffstats
path: root/meta-security/recipes-security/cynagora/cynagora-cynara-compat_2.1.bb
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2020-11-12 09:11:45 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-11-18 16:45:26 +0000
commit83ed8ca2cc7a48b99c5967a521553c202bd9e6c3 (patch)
tree3f72e8d855202d561f1a4e6055f2a346710f31c3 /meta-security/recipes-security/cynagora/cynagora-cynara-compat_2.1.bb
parent8512216f325e0f31f7d44e39017d0d12466d1ced (diff)
cynagora: Bump version 2.1
The version 2.1 fixes a critical database issue. Bug-AGL: SPEC-3677 Change-Id: I93fadbd1c12799d412724ea3e887d4910c74bbb1 Signed-off-by: José Bollo <jose.bollo@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25554 ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-security/recipes-security/cynagora/cynagora-cynara-compat_2.1.bb')
-rw-r--r--meta-security/recipes-security/cynagora/cynagora-cynara-compat_2.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-security/recipes-security/cynagora/cynagora-cynara-compat_2.1.bb b/meta-security/recipes-security/cynagora/cynagora-cynara-compat_2.1.bb
new file mode 100644
index 000000000..d83f95640
--- /dev/null
+++ b/meta-security/recipes-security/cynagora/cynagora-cynara-compat_2.1.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Cynara service with client libraries"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://Apache-2.0;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/cynagora;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "789282396dd80eaf08330425dabe1add53a47a9b"
+PV = "2.1+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+PROVIDES = "cynara"
+RPROVIDES_${PN} = "cynara"
+DEPENDS = "libcap"
+RDEPENDS_${PN} = "cynagora"
+
+EXTRA_OECMAKE += " \
+ -DWITH_SYSTEMD=OFF \
+ -DWITH_CYNARA_COMPAT=ON \
+ -DDIRECT_CYNARA_COMPAT=ON \
+"
+
+do_install_append() {
+ # remove cynagora stuff
+ rm $(find ${D} -name '*cynagora*')
+ # remove stupid test
+ rm -r ${D}${bindir}
+}
+