summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/conf/include/agl_s32g274ardb2.inc29
-rw-r--r--meta-agl-bsp/meta-alb/recipes-bsp/u-boot/u-boot-s32_%.bbappend5
-rw-r--r--meta-agl-bsp/meta-alb/recipes-kernel/linux/linux-s32_5.%.bbappend1
-rw-r--r--templates/machine/s32g274ardb2/40_bblayers.conf.inc8
-rw-r--r--templates/machine/s32g274ardb2/50_local.conf.inc3
-rw-r--r--templates/machine/s32g274ardb2/50_setup.sh2
-rw-r--r--templates/machine/s32g274ardb2/README_machine_s32g274ardb2.md6
7 files changed, 54 insertions, 0 deletions
diff --git a/meta-agl-bsp/conf/include/agl_s32g274ardb2.inc b/meta-agl-bsp/conf/include/agl_s32g274ardb2.inc
new file mode 100644
index 000000000..bd455f435
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_s32g274ardb2.inc
@@ -0,0 +1,29 @@
+# Disable meta-freescale package architecure mangling, as it causes
+# issues with AGL's explicit setting of DEFAULTTUNE.
+INHERIT:remove = "fsl-dynamic-packagearch"
+MACHINE_SOCARCH = "${TUNE_PKGARCH}"
+
+# Disable the meta-freescale weston-init bbappend as it conflicts
+# with AGL's.
+BBMASK:append = " meta-freescale/recipes-graphics/wayland/weston-init"
+
+# do not replace or append YP core recipes at all
+BBMASK:append = " meta-alb/dynamic-layers/core/"
+
+# Avoid needing meta-python2
+BBMASK:append = " meta-alb/dynamic-layers/freescale-layer/recipes-extended/vpp-core/vpp-core.bb"
+BBMASK:append = " meta-alb/recipes-(connectivity|core|devtools|extended/xen|support/rng-tools)/"
+
+# Seems like it might be worthwhile to get dunfell version, but doesn't work?:
+#BBMASK:append = " meta-alb/recipes-bsp/u-boot/u-boot.inc"
+
+PREFERRED_VERSION_rng-tools ?= "6%"
+
+# export?
+RELEASE_BASE = "release/bsp32.0"
+
+# the label needs to be shorter than we would expand to by default !!
+# Defaults to boot-${MACHINE} which happens to be more than 11 chars
+BOOTDD_VOLUME_ID = "boots32g"
+
+AGL_DEFAULT_IMAGE_FSTYPES ?= "sdcard ext4 tar.xz" \ No newline at end of file
diff --git a/meta-agl-bsp/meta-alb/recipes-bsp/u-boot/u-boot-s32_%.bbappend b/meta-agl-bsp/meta-alb/recipes-bsp/u-boot/u-boot-s32_%.bbappend
new file mode 100644
index 000000000..465023c08
--- /dev/null
+++ b/meta-agl-bsp/meta-alb/recipes-bsp/u-boot/u-boot-s32_%.bbappend
@@ -0,0 +1,5 @@
+# Missing from the meta-alb u-boot.inc
+inherit python3native
+
+DEPENDS:remove = "python-native"
+DEPENDS:append = " python3-native"
diff --git a/meta-agl-bsp/meta-alb/recipes-kernel/linux/linux-s32_5.%.bbappend b/meta-agl-bsp/meta-alb/recipes-kernel/linux/linux-s32_5.%.bbappend
new file mode 100644
index 000000000..787ead1ba
--- /dev/null
+++ b/meta-agl-bsp/meta-alb/recipes-kernel/linux/linux-s32_5.%.bbappend
@@ -0,0 +1 @@
+addtask merge_delta_config before do_kernel_localversion \ No newline at end of file
diff --git a/templates/machine/s32g274ardb2/40_bblayers.conf.inc b/templates/machine/s32g274ardb2/40_bblayers.conf.inc
new file mode 100644
index 000000000..c668d2792
--- /dev/null
+++ b/templates/machine/s32g274ardb2/40_bblayers.conf.inc
@@ -0,0 +1,8 @@
+# This must be parsed after qt5, etc. layers so that they are correctly
+# recognized by meta-freescale/dynamic-layers
+BBLAYERS =+ "\
+ ${METADIR}/bsp/meta-freescale \
+ ${METADIR}/bsp/meta-alb \
+ ${METADIR}/bsp/meta-linaro/meta-optee \
+ ${METADIR}/external/meta-python2 \
+ "
diff --git a/templates/machine/s32g274ardb2/50_local.conf.inc b/templates/machine/s32g274ardb2/50_local.conf.inc
new file mode 100644
index 000000000..3e15d4c99
--- /dev/null
+++ b/templates/machine/s32g274ardb2/50_local.conf.inc
@@ -0,0 +1,3 @@
+MACHINE = "s32g274ardb2"
+#see meta-agl/meta-agl-bsp/conf/include/agl_s32g233aevb.inc
+require conf/include/agl_s32g274ardb2.inc
diff --git a/templates/machine/s32g274ardb2/50_setup.sh b/templates/machine/s32g274ardb2/50_setup.sh
new file mode 100644
index 000000000..eefd1eb7f
--- /dev/null
+++ b/templates/machine/s32g274ardb2/50_setup.sh
@@ -0,0 +1,2 @@
+find_and_ack_eula $METADIR/bsp/meta-freescale EULA
+export EULA_FLAG_NAME="ACCEPT_FSL_EULA"
diff --git a/templates/machine/s32g274ardb2/README_machine_s32g274ardb2.md b/templates/machine/s32g274ardb2/README_machine_s32g274ardb2.md
new file mode 100644
index 000000000..59d80627b
--- /dev/null
+++ b/templates/machine/s32g274ardb2/README_machine_s32g274ardb2.md
@@ -0,0 +1,6 @@
+---
+description: S32G
+authors: Scott Murray <scott.murray@konsulko.com>
+---
+
+### Machine s32g274ardb2