summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/conf/include/agl_qemux86-64.inc13
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf1
-rw-r--r--meta-agl-bsp/wic/directdisk.wks.in9
-rw-r--r--meta-agl-distro/conf/distro/include/x86_64-tune.inc1
-rw-r--r--meta-agl/recipes-config/agl-login-manager/agl-login-manager_0.1.bb18
-rw-r--r--meta-agl/recipes-config/agl-login-manager/files/user-config.path8
-rw-r--r--meta-agl/recipes-config/agl-login-manager/files/user-config.service9
-rw-r--r--meta-agl/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_%.bbappend2
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb6
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.inc2
-rw-r--r--meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb3
-rw-r--r--meta-security/recipes-core/dbus-cynara/dbus-cynara_1.10.20.bb2
12 files changed, 30 insertions, 44 deletions
diff --git a/meta-agl-bsp/conf/include/agl_qemux86-64.inc b/meta-agl-bsp/conf/include/agl_qemux86-64.inc
index 165deae41..1fe839d68 100644
--- a/meta-agl-bsp/conf/include/agl_qemux86-64.inc
+++ b/meta-agl-bsp/conf/include/agl_qemux86-64.inc
@@ -3,19 +3,19 @@
# To get wide screen than default, there are a selection of resolutions
# available:
#
-#APPEND += "uvesafb.mode_option=1024x768-32"
-APPEND += "uvesafb.mode_option=1280x1024-32"
-#APPEND += "uvesafb.mode_option=1600x1200-32"
+#UVESA_MODE = "1024x768-32"
+UVESA_MODE = "1280x1024-32"
+#UVESA_MODE = "1600x1200-32"
#
# To avoid corrupt boot screen by systemd message, you can use serial
# console separated from VGA console or disable all boot messages by
# kernel command line.
#
# Configuration for serial console
-APPEND += "console=ttyS0,115200n8"
+QB_KERNEL_CMDLINE_APPEND_append = " console=ttyS0,115200n8"
#
# All boot message will be off
-APPEND += "quiet"
+QB_KERNEL_CMDLINE_APPEND_append = " quiet"
# Build updatable image. Only takes effect when sota.bbclass is inherited
DISTRO_FEATURES_append = " sota"
@@ -29,3 +29,6 @@ ROOT_VM = "root=PARTUUID=${DISK_SIGNATURE}-02"
# Force the virtio video device as 'vmware' doesn't always work
QB_OPT_APPEND_append = " -vga virtio"
+
+# Use our own wks file
+WKS_FILE="directdisk.wks.in"
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf b/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
index 1d2acf663..2b1ac5a7e 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
@@ -67,4 +67,5 @@ DISTRO_FEATURES_append = " bluetooth"
BBMASK += "/meta-rcar-gen3-adas/recipes-core/systemd/"
BBMASK += "/meta-rcar-gen3-adas/recipes-graphics/opencv/"
+BBMASK += "/meta-rcar-gen3-adas/recipes-devtools/valgrind/"
diff --git a/meta-agl-bsp/wic/directdisk.wks.in b/meta-agl-bsp/wic/directdisk.wks.in
new file mode 100644
index 000000000..f7b220cdb
--- /dev/null
+++ b/meta-agl-bsp/wic/directdisk.wks.in
@@ -0,0 +1,9 @@
+# short-description: Create a 'pcbios' direct disk image
+# long-description: Creates a partitioned legacy BIOS disk image that the user
+# can directly dd to boot media.
+
+part /boot --source bootimg-pcbios --use-uuid --label boot --active --align 1024
+part / --source rootfs --use-uuid --fstype=ext4 --label platform --align 1024
+
+bootloader --timeout=0 --append="rootwait rootfstype=ext4 ${QB_KERNEL_CMDLINE_APPEND}"
+
diff --git a/meta-agl-distro/conf/distro/include/x86_64-tune.inc b/meta-agl-distro/conf/distro/include/x86_64-tune.inc
index f3bfc372f..2efeca04d 100644
--- a/meta-agl-distro/conf/distro/include/x86_64-tune.inc
+++ b/meta-agl-distro/conf/distro/include/x86_64-tune.inc
@@ -51,6 +51,5 @@ QB_SYSTEM_NAME_x86-64 = "qemu-system-x86_64"
QB_CPU_x86-64 = "-cpu qemu64,+ssse3,+sse4.1,+sse4.2,+popcnt"
QB_CPU_KVM_x86-64 = "-cpu kvm64 -cpu qemu64,+ssse3,+sse4.1,+sse4.2,+popcnt"
-QB_KERNEL_CMDLINE_APPEND = "vga=0 uvesafb.mode_option=1024x768-32 oprofile.timer=1 uvesafb.task_timeout=-1"
# Add the 'virtio-rng-pci' device otherwise the guest may run out of entropy
QB_OPT_APPEND = "-vga vmware -show-cursor -usb -usbdevice tablet -device virtio-rng-pci"
diff --git a/meta-agl/recipes-config/agl-login-manager/agl-login-manager_0.1.bb b/meta-agl/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
index 22f52c4ec..cd6dc6792 100644
--- a/meta-agl/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
+++ b/meta-agl/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
@@ -5,28 +5,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384
inherit agl-graphical
-SRC_URI += " \
- file://user-config.service \
- file://user-config.path \
-"
-
LOGIN_USER ??="1001 1002"
RDEPENDS_${PN} += "af-main"
do_install_append() {
- install -d ${D}${systemd_user_unitdir}/default.target.wants
- install -m 0644 ${WORKDIR}/user-config.service ${D}${systemd_user_unitdir}
- install -m 0644 ${WORKDIR}/user-config.path ${D}${systemd_user_unitdir}
-
- sed -e 's,@DISPLAY_XDG_RUNTIME_DIR@,${DISPLAY_XDG_RUNTIME_DIR},g' \
- -i ${D}${systemd_user_unitdir}/user-config.service
- sed -e 's,@DISPLAY_XDG_RUNTIME_DIR@,${DISPLAY_XDG_RUNTIME_DIR},g' \
- -i ${D}${systemd_user_unitdir}/user-config.path
-
- ln -s ../user-config.path ${D}${systemd_user_unitdir}/default.target.wants/user-config.path
-
install -d ${D}${systemd_system_unitdir}/multi-user.target.wants/
for AGL_USER in ${LOGIN_USER};do
@@ -34,4 +18,4 @@ do_install_append() {
done
}
-FILES_${PN} += "${systemd_user_unitdir} ${systemd_system_unitdir}"
+FILES_${PN} += "${systemd_system_unitdir}"
diff --git a/meta-agl/recipes-config/agl-login-manager/files/user-config.path b/meta-agl/recipes-config/agl-login-manager/files/user-config.path
deleted file mode 100644
index 07f61f646..000000000
--- a/meta-agl/recipes-config/agl-login-manager/files/user-config.path
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Description=AGL user config unit path
-
-[Path]
-PathExists=@DISPLAY_XDG_RUNTIME_DIR@/wayland-0
-
-[Install]
-WantedBy=default.target
diff --git a/meta-agl/recipes-config/agl-login-manager/files/user-config.service b/meta-agl/recipes-config/agl-login-manager/files/user-config.service
deleted file mode 100644
index a66ba5327..000000000
--- a/meta-agl/recipes-config/agl-login-manager/files/user-config.service
+++ /dev/null
@@ -1,9 +0,0 @@
-[Unit]
-Description=AGL user config
-
-[Service]
-ExecStart=/bin/ln -sf @DISPLAY_XDG_RUNTIME_DIR@/wayland-0 %t/
-RemainAfterExit=yes
-
-[Install]
-WantedBy=default.target
diff --git a/meta-agl/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_%.bbappend b/meta-agl/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_%.bbappend
new file mode 100644
index 000000000..86a181fbb
--- /dev/null
+++ b/meta-agl/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_%.bbappend
@@ -0,0 +1,2 @@
+# libv4l2 is useful for making more efficient use of cameras via v4l2src.
+PACKAGECONFIG_append = " libv4l2"
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index e160486b2..68c878654 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -66,9 +66,11 @@ do_install_append_class-target() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d -m 0755 ${D}${systemd_user_unitdir}/default.target.wants
ln -s ../afm-user-daemon.service ${D}${systemd_user_unitdir}/default.target.wants/afm-user-daemon.service
- install -d -m 0755 ${D}${systemd_system_unitdir}/default.target.wants
+ ln -s ../afm-user-session.service ${D}${systemd_user_unitdir}/default.target.wants/afm-user-session.service
+ install -d -m 0755 ${D}${systemd_system_unitdir}/multi-user.target.wants
install -d -m 0755 ${D}${systemd_system_unitdir}/sockets.target.wants
- ln -sf ../afm-system-daemon.service ${D}${systemd_system_unitdir}/default.target.wants/afm-system-daemon.service
+ ln -sf ../afm-system-setup.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-system-setup.service
+ ln -sf ../afm-system-daemon.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-system-daemon.service
ln -sf ../afm-system-daemon.socket ${D}${systemd_system_unitdir}/sockets.target.wants/afm-system-daemon.socket
fi
echo "QT_WAYLAND_SHELL_INTEGRATION=ivi-shell" > ${D}${afm_confdir}/unit.env.d/qt-for-ivi-shell
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
index 13736aee3..77963bddb 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "1bec325ee85192eba57673750b9e4a77a1a970c8"
+SRCREV = "a752e8b3033fdeb6a52349fcc7fbd618907ab474"
PV = "${AGL_BRANCH}+git${SRCPV}"
S = "${WORKDIR}/git"
diff --git a/meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb b/meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb
index 44fabae06..84a951bce 100644
--- a/meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb
+++ b/meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb
@@ -30,13 +30,14 @@ RDEPENDS_${PN} += "\
packagegroup-ivi-common-test-ltp \
rt-tests \
stress \
- trinity \
"
# to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
# netperf
# FTBS, SPEC-316
# himeno
+# FTBS, SPEC-1384
+# trinity
# Packages for shell commands which are required by LTP
diff --git a/meta-security/recipes-core/dbus-cynara/dbus-cynara_1.10.20.bb b/meta-security/recipes-core/dbus-cynara/dbus-cynara_1.10.20.bb
index c46298e53..a97148366 100644
--- a/meta-security/recipes-core/dbus-cynara/dbus-cynara_1.10.20.bb
+++ b/meta-security/recipes-core/dbus-cynara/dbus-cynara_1.10.20.bb
@@ -12,6 +12,8 @@ SRC_URI_append = "\
"
DEPENDS += "cynara smack"
+RDEPENDS_${PN} += "dbus"
+
EXTRA_OECONF += "--enable-cynara --disable-selinux"
inherit distro_features_check