summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto/vbox-vmware-sata.cfg7
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend4
2 files changed, 11 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto/vbox-vmware-sata.cfg b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/vbox-vmware-sata.cfg
new file mode 100644
index 000000000..360a5a420
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/vbox-vmware-sata.cfg
@@ -0,0 +1,7 @@
+# enable harddrive driver for vmware/virtualbox
+CONFIG_ATA_PIIX=y
+CONFIG_SATA_AHCI=y
+CONFIG_ATA_SFF=y
+CONFIG_ATA_BMDMA=y
+CONFIG_ATA_GENERIC=y
+CONFIG_ATA_ACPI=y
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
index 6f1ed9bc3..7f7fdf5ff 100644
--- a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -5,3 +5,7 @@ SRC_URI += "file://fanotify.cfg \
file://uinput.cfg \
file://hid.cfg \
"
+
+# disk drivers for vmdk
+SRC_URI_append_qemux86 = " file://vbox-vmware-sata.cfg "
+SRC_URI_append_qemux86_64 = " file://vbox-vmware-sata.cfg "