summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--docs/devguides-book.yml15
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-kingfisher-conf_1.0.bb8
-rw-r--r--meta-agl-bsp/meta-sancloud/recipes-graphics/wayland/weston-ini-conf.bbappend3
-rw-r--r--meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe_%.bbappend2
-rw-r--r--meta-agl-bsp/meta-ti/recipes-graphics/wayland/weston-ini-conf.bbappend4
-rw-r--r--meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend2
-rw-r--r--meta-agl-distro/conf/distro/poky-agl.conf2
-rw-r--r--meta-agl-profile-core/recipes-connectivity/neardal/neardal/0002-neardal-lib-fix-memory-corruption.patch58
-rw-r--r--meta-agl-profile-core/recipes-connectivity/neardal/neardal_0.14.bb5
-rwxr-xr-xmeta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts2
-rw-r--r--meta-agl-profile-graphical/recipes-platform/images/agl-image-weston.bb2
11 files changed, 93 insertions, 10 deletions
diff --git a/docs/devguides-book.yml b/docs/devguides-book.yml
new file mode 100644
index 000000000..4bac5cb32
--- /dev/null
+++ b/docs/devguides-book.yml
@@ -0,0 +1,15 @@
+type: books
+books:
+-
+ id: meta-agl
+ title: Meta AGL
+ description: Meta AGL documentation
+ keywords:
+ author: "AGL"
+ version: flounder
+ chapters:
+ - url: ../README-AGL.md
+ name: AGL Overview
+ - url: ../README.md
+ destination: meta-agl.md
+ name: meta-agl \ No newline at end of file
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-kingfisher-conf_1.0.bb b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-kingfisher-conf_1.0.bb
index 748e59a8d..2c4192b98 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-kingfisher-conf_1.0.bb
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-kingfisher-conf_1.0.bb
@@ -10,10 +10,10 @@ inherit update-alternatives
RPROVIDES_${PN} += "virtual/gpsd-conf"
-ALTERNATIVE_${PN} = "gspd-defaults"
-ALTERNATIVE_LINK_NAME[gspd-defaults] = "${sysconfdir}/default/gpsd"
-ALTERNATIVE_TARGET[gspd-defaults] = "${sysconfdir}/default/gpsd.kingfisher"
-ALTERNATIVE_PRIORITY[gspd-defaults] = "20"
+ALTERNATIVE_${PN} = "gpsd-defaults"
+ALTERNATIVE_LINK_NAME[gpsd-defaults] = "${sysconfdir}/default/gpsd"
+ALTERNATIVE_TARGET[gpsd-defaults] = "${sysconfdir}/default/gpsd.kingfisher"
+ALTERNATIVE_PRIORITY[gpsd-defaults] = "20"
COMPATIBLE_MACHINE = "ulcb"
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-agl-bsp/meta-sancloud/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-sancloud/recipes-graphics/wayland/weston-ini-conf.bbappend
new file mode 100644
index 000000000..f2a27ba3c
--- /dev/null
+++ b/meta-agl-bsp/meta-sancloud/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -0,0 +1,3 @@
+do_configure_append_bbe() {
+ echo 'gbm-format=rgb565' >> ${WORKDIR}/core.cfg
+}
diff --git a/meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe_%.bbappend b/meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe_%.bbappend
new file mode 100644
index 000000000..02161415f
--- /dev/null
+++ b/meta-agl-bsp/meta-sancloud/recipes-kernel/linux/linux-bbe_%.bbappend
@@ -0,0 +1,2 @@
+require recipes-kernel/linux/linux-agl.inc
+require recipes-kernel/linux/linux-agl-4.9.inc
diff --git a/meta-agl-bsp/meta-ti/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-ti/recipes-graphics/wayland/weston-ini-conf.bbappend
index 914a87309..684031eae 100644
--- a/meta-agl-bsp/meta-ti/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -2,6 +2,6 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
# While we could have a panel attached to HDMI, we only use the default
# panel isntead.
-SRC_URI_remove = "file://hdmi-a-1-270.cfg"
+SRC_URI_remove_dra7xx-evm = "file://hdmi-a-1-270.cfg"
# Our DPI panel shows up as "UNNAMED-1"
-SRC_URI += "file://unnamed.cfg"
+SRC_URI_append_dra7xx-evm = " file://unnamed.cfg"
diff --git a/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend b/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
index fde74c878..356f24fa3 100644
--- a/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
@@ -1,4 +1,5 @@
require recipes-kernel/linux/linux-agl.inc
+require recipes-kernel/linux/linux-agl-4.9.inc
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
@@ -7,5 +8,6 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI += " \
file://dcan2_pinmux_enable.patch \
+ file://fix_dcan_addresses.patch \
"
diff --git a/meta-agl-distro/conf/distro/poky-agl.conf b/meta-agl-distro/conf/distro/poky-agl.conf
index ba8094afb..003f2f37e 100644
--- a/meta-agl-distro/conf/distro/poky-agl.conf
+++ b/meta-agl-distro/conf/distro/poky-agl.conf
@@ -8,7 +8,7 @@ DISTRO_NAME = "Automotive Grade Linux"
# Release flags
DISTRO_CODENAME = "flounder"
AGL_BRANCH = "flounder"
-AGLVERSION = "6.0.3"
+AGLVERSION = "6.0.4"
# switch devel/release
AGLRELEASETYPE ?= "agldevelopment"
#AGLRELEASETYPE ?= "aglrelease"
diff --git a/meta-agl-profile-core/recipes-connectivity/neardal/neardal/0002-neardal-lib-fix-memory-corruption.patch b/meta-agl-profile-core/recipes-connectivity/neardal/neardal/0002-neardal-lib-fix-memory-corruption.patch
new file mode 100644
index 000000000..d40d9a4fe
--- /dev/null
+++ b/meta-agl-profile-core/recipes-connectivity/neardal/neardal/0002-neardal-lib-fix-memory-corruption.patch
@@ -0,0 +1,58 @@
+From ee6267f357b3d158f0a0e88460782e8b9d44274a Mon Sep 17 00:00:00 2001
+From: Raquel Medina <raquel.medina@konsulko.com>
+Date: Fri, 4 Jan 2019 07:43:03 -0500
+Subject: [PATCH] neardal: lib: fix memory corruption
+
+ The current commit fixes an invalid memory access
+ which manifests as a random segfault when executing
+ continuous tag read operations.
+
+ The corruption happens when releasing the memory allocated to a
+ record: in the time between the memory being g_free'd and the
+ subsequent memset operation, the memory could have been reused by
+ some other process. And since memory allocation depends on
+ system-wide factors, it makes this bug hard to track.
+
+ Tested using ACR122U reader and NTAG213
+ tags on Automotive Grade Linux (flounder,
+ guppy and master branches)
+
+Signed-off-by: Raquel Medina <raquel.medina@konsulko.com>
+---
+ lib/neardal_record.c | 1 -
+ lib/neardal_tools.c | 5 ++++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/lib/neardal_record.c b/lib/neardal_record.c
+index 669012c..cfed5e8 100644
+--- a/lib/neardal_record.c
++++ b/lib/neardal_record.c
+@@ -31,7 +31,6 @@ void neardal_record_free(neardal_record *r)
+ {
+ g_return_if_fail(r);
+ neardal_g_strfreev((void **) r, &r->uriObjSize);
+- memset(r, 0, sizeof(*r));
+ }
+
+ void neardal_free_record(neardal_record *record) \
+diff --git a/lib/neardal_tools.c b/lib/neardal_tools.c
+index f0d6157..f307df6 100644
+--- a/lib/neardal_tools.c
++++ b/lib/neardal_tools.c
+@@ -32,9 +32,12 @@
+ void neardal_g_strfreev(void **array, void *end)
+ {
+ void **p = array;
+- for (; (void *) p < end; p++)
++ for (; (void *) p < end; p++) {
+ g_free(*p);
++ *p = NULL;
++ }
+ g_free(array);
++ array = NULL;
+ }
+
+ void neardal_g_variant_add_parsed(GVariant **v, const char *format, ...)
+--
+2.17.1
+
diff --git a/meta-agl-profile-core/recipes-connectivity/neardal/neardal_0.14.bb b/meta-agl-profile-core/recipes-connectivity/neardal/neardal_0.14.bb
index 022e54e26..8bec79e67 100644
--- a/meta-agl-profile-core/recipes-connectivity/neardal/neardal_0.14.bb
+++ b/meta-agl-profile-core/recipes-connectivity/neardal/neardal_0.14.bb
@@ -2,7 +2,8 @@ require neardal.inc
SRC_URI = "https://github.com/connectivity/neardal/archive/${PV}.tar.gz \
file://ncl.patch \
- file://0001-neardal-ncl-fix-segfault-on-help-page-being-displaye.patch \
- "
+ file://0001-neardal-ncl-fix-segfault-on-help-page-being-displaye.patch \
+ file://0002-neardal-lib-fix-memory-corruption.patch \
+ "
SRC_URI[md5sum] = "3dbda58253ca30ee6a7a7573eaa68f40"
SRC_URI[sha256sum] = "157d320bd831d91a82203d9697d2d2a2cebdb515d6e1c4ce04fe8ef27d1da615"
diff --git a/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts b/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts
index 1d1a5a059..a044fb753 100755
--- a/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts
+++ b/meta-agl-profile-core/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts
@@ -45,4 +45,6 @@ systemctl daemon-reload
# since all postinstalls executed successfully, remove the postinstalls directory
if [ $remove_agl_pi_dir = 1 ]; then
rm -rf $agl_pi_dir
+ exit 0
fi
+exit 1
diff --git a/meta-agl-profile-graphical/recipes-platform/images/agl-image-weston.bb b/meta-agl-profile-graphical/recipes-platform/images/agl-image-weston.bb
index 6c9bee7f1..bbb61c922 100644
--- a/meta-agl-profile-graphical/recipes-platform/images/agl-image-weston.bb
+++ b/meta-agl-profile-graphical/recipes-platform/images/agl-image-weston.bb
@@ -5,5 +5,5 @@ require agl-image-weston.inc
LICENSE = "MIT"
IMAGE_INSTALL_append = "\
- profile-agl-graphical \
+ packagegroup-agl-profile-graphical \
"