aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl/recipes-automotive/hvacplugin/files/hvacplugin7
-rw-r--r--meta-agl/recipes-automotive/hvacplugin/hvacplugin_0.1.bb26
-rw-r--r--meta-agl/recipes-core/packagegroups/packagegroup-agl-core-automotive.bb1
3 files changed, 34 insertions, 0 deletions
diff --git a/meta-agl/recipes-automotive/hvacplugin/files/hvacplugin b/meta-agl/recipes-automotive/hvacplugin/files/hvacplugin
new file mode 100644
index 000000000..8a1a90da6
--- /dev/null
+++ b/meta-agl/recipes-automotive/hvacplugin/files/hvacplugin
@@ -0,0 +1,7 @@
+{
+ "name" : "hvacplugin",
+ "path" : "/usr/lib/automotive-message-broker/hvacplugin.so",
+ "delay" : "30",
+ "enabled" : true
+}
+
diff --git a/meta-agl/recipes-automotive/hvacplugin/hvacplugin_0.1.bb b/meta-agl/recipes-automotive/hvacplugin/hvacplugin_0.1.bb
new file mode 100644
index 000000000..9692e2d0f
--- /dev/null
+++ b/meta-agl/recipes-automotive/hvacplugin/hvacplugin_0.1.bb
@@ -0,0 +1,26 @@
+SUMMARY = "hvacplugin"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+ file://hvacplugin.cpp;startline=4;endline=11;md5=5adb69b6702cd5745961047a30ef560a"
+
+SRC_URI = "git://github.com/iotbzh/hvacplugin \
+ file://hvacplugin \
+ "
+SRCREV = "253e3d98505108f652ba875544fde4f58d4714c8"
+S = "${WORKDIR}/git"
+
+DEPENDS = "glib-2.0 json-c automotive-message-broker"
+RDEPENDS_{PN} = "automotive-message-broker"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE += "-DPLUGIN_INSTALL_PATH=${libdir}/automotive-message-broker"
+
+do_install_append() {
+ install -Dm 0644 ${WORKDIR}/hvacplugin ${D}/${sysconfdir}/ambd/plugins.d/hvacplugin
+}
+
+FILES_${PN} += "${libdir}/automotive-message-broker/*.so"
+FILES_${PN}-dbg += "${libdir}/automotive-message-broker/.debug"
+
diff --git a/meta-agl/recipes-core/packagegroups/packagegroup-agl-core-automotive.bb b/meta-agl/recipes-core/packagegroups/packagegroup-agl-core-automotive.bb
index d9f2279e1..c99b29a9f 100644
--- a/meta-agl/recipes-core/packagegroups/packagegroup-agl-core-automotive.bb
+++ b/meta-agl/recipes-core/packagegroups/packagegroup-agl-core-automotive.bb
@@ -10,4 +10,5 @@ PACKAGES = "\
ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
+ hvacplugin \
"