aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ivi-common/recipes-test/ipv6connect/ipv6connect.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-test/ipv6connect/ipv6connect.bb b/meta-ivi-common/recipes-test/ipv6connect/ipv6connect.bb
new file mode 100644
index 000000000..2fc6933ea
--- /dev/null
+++ b/meta-ivi-common/recipes-test/ipv6connect/ipv6connect.bb
@@ -0,0 +1,22 @@
+SUMMARY = "ipv6connect test"
+HOMEPAGE = "https://chromium.googlesource.com/chromiumos/third_party/autotest/+/0.12.369.B/client/tests/ipv6connect"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${S}/${PN}/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=master"
+SRCREV = "b355b7e1f43a19938895964f314484ffd8a39542"
+
+inherit autotools
+
+B = "${WORKDIR}/git/ipv6connect"
+S = "${WORKDIR}/git"
+
+# configure script is not delivered, only a makefile.
+do_configure() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${B}/ipv6connect ${D}${bindir}
+}