aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb4
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.inc3
2 files changed, 7 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
index bc4352dc7..5edab2ac1 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
@@ -16,10 +16,14 @@ SRC_URI = "${SRC_URI_git} \
"
SRCREV = "17e428f46f0e093270be7eff79788e1575bcfb14"
+PV = "dab+git${SRCPV}"
+
S = "${WORKDIR}/git"
inherit cmake pkgconfig
+CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+
pkg_postinst_${PN}() {
mkdir -p "$D${libdir}/afb"
}
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
index 54d6d3026..8d67c66c1 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
@@ -15,6 +15,7 @@ SRC_URI = "${SRC_URI_git} \
"
SRCREV = "f36bbef97187012b84f4620fea7cea440741981f"
+PV = "dab+git${SRCPV}"
S = "${WORKDIR}/git"
@@ -24,3 +25,5 @@ afm_datadir = "/var/local/lib/${afm_name}"
afb_binding_dir = "${libdir}/afb"
systemd_units_root = "/usr/local/lib/systemd"
+CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+