aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index b71a4cba3..33d380d05 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -84,7 +84,7 @@ do_install_append_porter() {
pkg_postinst_${PN}() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
for SYS in "system" "user";do
- for DEST in "default.target.wants" ".";do
+ for DEST in "sockets.target.wants" "default.target.wants" ".";do
chgrp ${afm_name} $D${systemd_units_root}/${SYS}/${DEST};
done
done
@@ -98,7 +98,7 @@ pkg_postinst_${PN}() {
pkg_postinst_${PN}_smack() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
for SYS in "system" "user";do
- for DEST in "default.target.wants" ".";do
+ for DEST in "sockets.target.wants" "default.target.wants" ".";do
chgrp ${afm_name} $D${systemd_units_root}/${SYS}/${DEST};
chsmack -a 'System::Shared' -t $D${systemd_units_root}/${SYS}/${DEST};
done