summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-app-framework/recipes-core/systemd/systemd_%.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/systemd/systemd_%.bbappend b/meta-app-framework/recipes-core/systemd/systemd_%.bbappend
new file mode 100644
index 000000000..6b8057a5c
--- /dev/null
+++ b/meta-app-framework/recipes-core/systemd/systemd_%.bbappend
@@ -0,0 +1,20 @@
+##################################################################################
+# This patch is temporary.
+# This is a solution to the Bug-AGL SPEC-539.
+#
+# It renames the file udev-smack-default.rules
+# as the file 55-smack-default.rules before installation in do_install.
+# This comes from https://github.com/01org/meta-intel-iot-security.git
+# (meta-security-smack/recipes-core/systemd/)
+# It should be removed when the security layer will be refited to meta-security
+# See git clone http://git.yoctoproject.org/cgit/cgit.cgi/meta-security
+#
+# It also renames the file touchscreen.rules as the file 55-touchscreen.rules
+# This comes with the recipe systemd_230 of poky (meta/recipes-core/systemd)
+# It should be removed when poky changes.
+##################################################################################
+do_install_prepend() {
+ mv ${WORKDIR}/udev-smack-default.rules ${WORKDIR}/55-smack-default.rules || true
+ mv ${WORKDIR}/touchscreen.rules ${WORKDIR}/55-touchscreen.rules || true
+}
+