summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-profile-core/recipes-kernel/most/most.bbappend18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta-agl-profile-core/recipes-kernel/most/most.bbappend b/meta-agl-profile-core/recipes-kernel/most/most.bbappend
index d85565fc2..4ebcba88d 100644
--- a/meta-agl-profile-core/recipes-kernel/most/most.bbappend
+++ b/meta-agl-profile-core/recipes-kernel/most/most.bbappend
@@ -1,7 +1,21 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+def prep_version (d) :
+ KV = d.getVar('KERNEL_VERSION', True)
+ if not KV :
+ return "4.12"
+ else:
+ return KV
+
+ORIG_KERN_VER = "${@prep_version(d)}"
+
+VANILLA_KERNEL_VERSION = "${@str(ORIG_KERN_VER.split("-")[0].split(".")[0]+ORIG_KERN_VER.split("-")[0].split(".")[1])}"
+
+APPLY = "${@str('no' if ${VANILLA_KERNEL_VERSION} > 412 else 'yes')}"
+
SRC_URI_append = " \
- file://0002-src-most-add-auto-conf-feature.patch \
+ file://0001-most-aim-network-backport-Kernel-API.patch;apply=${APPLY} \
+ file://0002-src-most-add-auto-conf-feature.patch \
file://0003-core-remove-kernel-log-for-MBO-status.patch \
file://0004-most-video-set-device_caps.patch \
file://0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch \
@@ -10,3 +24,5 @@ SRC_URI_append = " \
file://0008-dim2-read-clock-speed-from-the-device-tree.patch \
file://0009-dim2-use-device-for-coherent-memory-allocation.patch \
"
+# Make sure we can expose KERNEL_VERSION ...
+do_patch[depends] = "virtual/kernel:do_populate_sysroot"