aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/0001-obex-report-notification-status-on-incoming-message.patch26
-rw-r--r--meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend5
2 files changed, 30 insertions, 1 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/0001-obex-report-notification-status-on-incoming-message.patch b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/0001-obex-report-notification-status-on-incoming-message.patch
new file mode 100644
index 000000000..44bae715e
--- /dev/null
+++ b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5/0001-obex-report-notification-status-on-incoming-message.patch
@@ -0,0 +1,26 @@
+From 0d85faf308285c6a1f77f01660a2ce0541bfa5b4 Mon Sep 17 00:00:00 2001
+From: Matt Ranostay <matt.ranostay@konsulko.com>
+Date: Wed, 12 Jun 2019 17:04:00 -0700
+Subject: [PATCH] obex: report notification status on incoming message
+
+To match doc/obex.txt on incoming message notification the respective
+Status field should be set.
+---
+ obexd/client/map.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/obexd/client/map.c b/obexd/client/map.c
+index 550c5afb4..23be2d6b2 100644
+--- a/obexd/client/map.c
++++ b/obexd/client/map.c
+@@ -1914,6 +1914,7 @@ static void map_handle_notification(struct map_event *event, void *user_data)
+ switch (event->type) {
+ case MAP_ET_NEW_MESSAGE:
+ map_handle_new_message(map, event);
++ map_handle_status_changed(map, event, "notification");
+ break;
+ case MAP_ET_DELIVERY_SUCCESS:
+ map_handle_status_changed(map, event, "delivery-success");
+--
+2.20.1
+
diff --git a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
index 1ab375645..736f18c79 100644
--- a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
@@ -1,5 +1,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-SRC_URI_append = " file://bluetooth.conf"
+SRC_URI_append = " \
+ file://bluetooth.conf \
+ file://0001-obex-report-notification-status-on-incoming-message.patch \
+"
do_install_append() {
install -m 0644 ${WORKDIR}/bluetooth.conf ${D}${sysconfdir}/dbus-1/system.d/bluetooth.conf