aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/meta-intel/recipes-graphics/wayland/libva_%.bbappend2
-rw-r--r--meta-agl/recipes-core/psplash/psplash_git.bbappend6
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-agl-bsp/meta-intel/recipes-graphics/wayland/libva_%.bbappend b/meta-agl-bsp/meta-intel/recipes-graphics/wayland/libva_%.bbappend
index efc194b79..eda8de38a 100644
--- a/meta-agl-bsp/meta-intel/recipes-graphics/wayland/libva_%.bbappend
+++ b/meta-agl-bsp/meta-intel/recipes-graphics/wayland/libva_%.bbappend
@@ -1,4 +1,4 @@
# This patch correct a bug in libva1_1.7.0.bb 1.8 inmeta-intel (no clue when it will be fixed)
# libva.bb calls for an x11 runtime dependency even if wayland is selected
#
-RDEPENDS_${PN}-egl_remove = "${@base_contains("DISTRO_FEATURES", "x11", "", "${PN}-x11", d)}"
+RDEPENDS_${PN}-egl_remove = "${@bb.utils.contains("DISTRO_FEATURES", "x11", "", "${PN}-x11", d)}"
diff --git a/meta-agl/recipes-core/psplash/psplash_git.bbappend b/meta-agl/recipes-core/psplash/psplash_git.bbappend
index 3b4f85102..c2c58c562 100644
--- a/meta-agl/recipes-core/psplash/psplash_git.bbappend
+++ b/meta-agl/recipes-core/psplash/psplash_git.bbappend
@@ -9,8 +9,8 @@ SPLASH_IMAGES="file://psplash-poky-img.h;outsuffix=default"
inherit systemd
-SYSTEMD_PACKAGES = "${@base_contains('DISTRO_FEATURES', 'systemd', '${PN}', '', d)}"
-SYSTEMD_SERVICE_${PN} = "${@base_contains('DISTRO_FEATURES', 'systemd', 'psplash-start.service psplash-quit.service', '', d)}"
+SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${PN}', '', d)}"
+SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'psplash-start.service psplash-quit.service', '', d)}"
do_configure_append () {
cd ${S}
@@ -18,7 +18,7 @@ do_configure_append () {
}
do_install_append () {
- if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
install -d ${D}${systemd_unitdir}/system
install -m 644 ${WORKDIR}/*.service ${D}/${systemd_unitdir}/system
fi