summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/conf/layer.conf2
-rw-r--r--meta-agl-bsp/wic/systemd-intel-corei7-64-bootdisk.wks4
-rw-r--r--meta-agl-bsp/wic/systemd-joule-bootdisk.wks4
-rw-r--r--meta-agl-distro/conf/layer.conf2
-rw-r--r--meta-agl/conf/layer.conf2
-rw-r--r--meta-app-framework/conf/layer.conf2
-rw-r--r--meta-ivi-common/conf/layer.conf2
-rw-r--r--meta-netboot/conf/layer.conf2
-rw-r--r--meta-security/conf/layer.conf2
-rwxr-xr-xscripts/mkabl-agl.sh3
-rwxr-xr-xscripts/mkefi-agl.sh3
11 files changed, 17 insertions, 11 deletions
diff --git a/meta-agl-bsp/conf/layer.conf b/meta-agl-bsp/conf/layer.conf
index 031c4f2be..7c996cafe 100644
--- a/meta-agl-bsp/conf/layer.conf
+++ b/meta-agl-bsp/conf/layer.conf
@@ -21,4 +21,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "aglbsp"
BBFILE_PATTERN_aglbsp = "^${LAYERDIR}/"
-BBFILE_PRIORITY_aglbsp = "10"
+BBFILE_PRIORITY_aglbsp = "60"
diff --git a/meta-agl-bsp/wic/systemd-intel-corei7-64-bootdisk.wks b/meta-agl-bsp/wic/systemd-intel-corei7-64-bootdisk.wks
index 605d622a6..56393728b 100644
--- a/meta-agl-bsp/wic/systemd-intel-corei7-64-bootdisk.wks
+++ b/meta-agl-bsp/wic/systemd-intel-corei7-64-bootdisk.wks
@@ -3,9 +3,9 @@
# can directly dd to boot media. The selected bootloader is systemd-boot
# and we do not have swap
-part /boot --source bootimg-efi --sourceparams="loader=systemd-boot,initrd=microcode.cpio" --ondisk sda --label msdos --active --align 1024
+part /boot --source bootimg-efi --sourceparams="loader=systemd-boot,initrd=microcode.cpio" --use-uuid --label msdos --active --align 1024
-part / --source rootfs --ondisk sda --fstype=ext4 --label platform --align 1024 --use-uuid
+part / --source rootfs --fstype=ext4 --label platform --align 1024 --use-uuid
# Modify the append line here as needed to suit the environment.
#
diff --git a/meta-agl-bsp/wic/systemd-joule-bootdisk.wks b/meta-agl-bsp/wic/systemd-joule-bootdisk.wks
index 87b006f07..a318e2315 100644
--- a/meta-agl-bsp/wic/systemd-joule-bootdisk.wks
+++ b/meta-agl-bsp/wic/systemd-joule-bootdisk.wks
@@ -4,9 +4,9 @@
# and we do not have swap. We assume a Joule system and provide an
# appropriate kernel command line.
-part /boot --source bootimg-efi --sourceparams="loader=systemd-boot,initrd=microcode.cpio" --ondisk sda --label msdos --active --align 1024
+part /boot --source bootimg-efi --sourceparams="loader=systemd-boot,initrd=microcode.cpio" --use-uuid --label msdos --active --align 1024
-part / --source rootfs --ondisk sda --fstype=ext4 --label platform --align 1024 --use-uuid
+part / --source rootfs --fstype=ext4 --label platform --align 1024 --use-uuid
# Modify the append line here as needed to suit the environment
bootloader --ptable gpt --timeout=5 --append="rootwait rootfstype=ext4 console=ttyS2,115200n8 console=tty0 video=efifb maxcpus=4 noxsave reboot=efi kmemleak=off"
diff --git a/meta-agl-distro/conf/layer.conf b/meta-agl-distro/conf/layer.conf
index 74527516a..9810f4a3e 100644
--- a/meta-agl-distro/conf/layer.conf
+++ b/meta-agl-distro/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "agl-distro"
BBFILE_PATTERN_agl-distro = "^${LAYERDIR}/"
-BBFILE_PRIORITY_agl-distro = "8"
+BBFILE_PRIORITY_agl-distro = "70"
diff --git a/meta-agl/conf/layer.conf b/meta-agl/conf/layer.conf
index 4943147e5..dd0784a0a 100644
--- a/meta-agl/conf/layer.conf
+++ b/meta-agl/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "agl"
BBFILE_PATTERN_agl = "^${LAYERDIR}/"
-BBFILE_PRIORITY_agl = "7"
+BBFILE_PRIORITY_agl = "70"
diff --git a/meta-app-framework/conf/layer.conf b/meta-app-framework/conf/layer.conf
index f74ebd658..97ca5524a 100644
--- a/meta-app-framework/conf/layer.conf
+++ b/meta-app-framework/conf/layer.conf
@@ -7,5 +7,5 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "app-framework"
BBFILE_PATTERN_app-framework = "^${LAYERDIR}/"
-BBFILE_PRIORITY_app-framework = "7"
+BBFILE_PRIORITY_app-framework = "70"
diff --git a/meta-ivi-common/conf/layer.conf b/meta-ivi-common/conf/layer.conf
index e19cacc4f..42517232a 100644
--- a/meta-ivi-common/conf/layer.conf
+++ b/meta-ivi-common/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "ivi-common"
BBFILE_PATTERN_ivi-common = "^${LAYERDIR}/"
-BBFILE_PRIORITY_ivi-common = "7"
+BBFILE_PRIORITY_ivi-common = "70"
diff --git a/meta-netboot/conf/layer.conf b/meta-netboot/conf/layer.conf
index 324f1f1bb..7ee6f6f0c 100644
--- a/meta-netboot/conf/layer.conf
+++ b/meta-netboot/conf/layer.conf
@@ -10,4 +10,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "meta-netboot"
BBFILE_PATTERN_meta-netboot = "^${LAYERDIR}/"
-BBFILE_PRIORITY_meta-netboot = "20"
+BBFILE_PRIORITY_meta-netboot = "60"
diff --git a/meta-security/conf/layer.conf b/meta-security/conf/layer.conf
index c051e5885..db6be54c0 100644
--- a/meta-security/conf/layer.conf
+++ b/meta-security/conf/layer.conf
@@ -9,4 +9,4 @@ BBFILES := "${BBFILES} \
# Must prioritize our rpm recipe over the default ones.
BBFILE_COLLECTIONS += "security-smack"
BBFILE_PATTERN_security-smack := "^${LAYERDIR}/"
-BBFILE_PRIORITY_security-smack = "8"
+BBFILE_PRIORITY_security-smack = "60"
diff --git a/scripts/mkabl-agl.sh b/scripts/mkabl-agl.sh
index 8483d231d..611c08fbc 100755
--- a/scripts/mkabl-agl.sh
+++ b/scripts/mkabl-agl.sh
@@ -375,6 +375,7 @@ ROOTFS_DISKID=$(fdisk -l "$DEVICE" | grep -e "Disk identifier" | sed -n 's/^.*Di
if [ $ROOTFS_DISKID = "" ]; then
die "Failed to read DISKID"
fi
+BOOTFS_PARTUUID="$ROOTFS_DISKID-01"
ROOTFS_PARTUUID="$ROOTFS_DISKID-02"
debug "PARTUUID for ROOTFS is $ROOTFS_PARTUUID"
@@ -476,6 +477,8 @@ fi
debug "removing any swap entry in /etc/fstab"
sed --in-place '/swap/d' $ROOTFS_MNT/etc/fstab
+debug "fixing PARTUUID for /boot"
+sed --in-place -e "s#PARTUUID=[0-9a-z-]\+\t/boot#${BOOTFS_PARTUUID}\t/boot#" $ROOTFS_MNT/etc/fstab
printf "flushing data on removable device. May take a while ... "
sync --file-system $ROOTFS_MNT
diff --git a/scripts/mkefi-agl.sh b/scripts/mkefi-agl.sh
index 14ade366e..48a0af44d 100755
--- a/scripts/mkefi-agl.sh
+++ b/scripts/mkefi-agl.sh
@@ -352,6 +352,7 @@ ROOTFS_DISKID=$(fdisk -l "$DEVICE" | grep -e "Disk identifier" | sed -n 's/^.*Di
if [ $ROOTFS_DISKID = "" ]; then
die "Failed to read DISKID"
fi
+BOOTFS_PARTUUID="$ROOTFS_DISKID-01"
ROOTFS_PARTUUID="$ROOTFS_DISKID-02"
debug "PARTUUID for ROOTFS is $ROOTFS_PARTUUID"
@@ -500,6 +501,8 @@ else
fi
debug "removing any swap entry in /etc/fstab"
sed --in-place '/swap/d' $ROOTFS_MNT/etc/fstab
+debug "fixing PARTUUID for /boot"
+sed --in-place -e "s#PARTUUID=[0-9a-z-]\+\t/boot#${BOOTFS_PARTUUID}\t/boot#" $ROOTFS_MNT/etc/fstab
printf "flushing data on removable device. May take a while ... "
sync --file-system $ROOTFS_MNT