summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-2.0.0/fix-ivi-layout-for-IMX6-fbdev.patch13
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_2.0.0.bbappend1
-rw-r--r--meta-agl/recipes-config/agl-login-manager/files/user-config.service1
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc2
4 files changed, 16 insertions, 1 deletions
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-2.0.0/fix-ivi-layout-for-IMX6-fbdev.patch b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-2.0.0/fix-ivi-layout-for-IMX6-fbdev.patch
new file mode 100644
index 000000000..2f4e6b628
--- /dev/null
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-2.0.0/fix-ivi-layout-for-IMX6-fbdev.patch
@@ -0,0 +1,13 @@
+--- a/ivi-shell/ivi-layout.c 2018-01-09 12:36:35.595811484 +0200
++++ b/ivi-shell/ivi-layout.c 2018-01-09 12:39:59.579122491 +0200
+@@ -629,10 +629,6 @@
+ struct ivi_rectangle r;
+ bool can_calc = true;
+
+- /*In case of no prop change, this just returns*/
+- if (!ivilayer->prop.event_mask && !ivisurf->prop.event_mask)
+- return;
+-
+ update_opacity(ivilayer, ivisurf, ivi_view->view);
+
+ if (ivisurf->prop.source_width == 0 || ivisurf->prop.source_height == 0) {
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_2.0.0.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_2.0.0.bbappend
index 683219968..5cc743326 100644
--- a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_2.0.0.bbappend
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_2.0.0.bbappend
@@ -4,6 +4,7 @@ SRC_URI_append_imxgpu3d = " \
file://0001-libweston-Restore-EGL-support-for-the-fbdev-backend.patch \
file://0002-MGS-2352-ccc-Add-GPU-VIV-support-for-weston-2.0.patch \
file://0006-Link-compositor-to-egl.patch \
+ file://fix-ivi-layout-for-IMX6-fbdev.patch \
"
# The 'egl' configuration of weston requires gles support, and consideration
diff --git a/meta-agl/recipes-config/agl-login-manager/files/user-config.service b/meta-agl/recipes-config/agl-login-manager/files/user-config.service
index 0bf37fb4b..a66ba5327 100644
--- a/meta-agl/recipes-config/agl-login-manager/files/user-config.service
+++ b/meta-agl/recipes-config/agl-login-manager/files/user-config.service
@@ -3,6 +3,7 @@ Description=AGL user config
[Service]
ExecStart=/bin/ln -sf @DISPLAY_XDG_RUNTIME_DIR@/wayland-0 %t/
+RemainAfterExit=yes
[Install]
WantedBy=default.target
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc
index 586f44e91..ac55b5f02 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "adb89e71f1c366b0cabdf9e04aaed60b84a96f0e"
+SRCREV = "9c1c9a1ba46eb9ddada4167ce9d20143ee3c9636"
PV = "${AGL_BRANCH}+git${SRCPV}"
S = "${WORKDIR}/git"