summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor-init-pipewire.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init-pipewire.bb b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init-pipewire.bb
index f1d73732a..c42cb9793 100644
--- a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init-pipewire.bb
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init-pipewire.bb
@@ -12,22 +12,23 @@ SRC_URI = "file://agl-compositor-pipewire.conf \
file://agl-compositor-stream-pipewire.service \
"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
AGL_KVM_REMOTE_OUTPUT_IP ?= "172.16.10.3"
AGL_KVM_REMOTE_OUTPUT_PORT ?= "5005"
do_install() {
sed -i -e "s,@REMOTE_OUTPUT_IP@,${AGL_KVM_REMOTE_OUTPUT_IP},g" \
- ${WORKDIR}/agl-compositor-stream-pipewire.service
+ ${UNPACKDIR}/agl-compositor-stream-pipewire.service
sed -i -e "s,@REMOTE_OUTPUT_PORT@,${AGL_KVM_REMOTE_OUTPUT_PORT},g" \
- ${WORKDIR}/agl-compositor-stream-pipewire.service
+ ${UNPACKDIR}/agl-compositor-stream-pipewire.service
- install -D -p -m0644 ${WORKDIR}/agl-compositor-stream-pipewire.service ${D}${systemd_system_unitdir}/agl-compositor-stream-pipewire.service
+ install -D -p -m0644 ${UNPACKDIR}/agl-compositor-stream-pipewire.service ${D}${systemd_system_unitdir}/agl-compositor-stream-pipewire.service
install -d ${D}${systemd_system_unitdir}/agl-compositor.service.d
- install -m644 ${WORKDIR}/agl-compositor-pipewire.conf ${D}/${systemd_system_unitdir}/agl-compositor.service.d/02-agl-compositor.conf
+ install -m644 ${UNPACKDIR}/agl-compositor-pipewire.conf ${D}/${systemd_system_unitdir}/agl-compositor.service.d/02-agl-compositor.conf
}
FILES:${PN} += "\