summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-app-framework/recipes-core/applaunchd/applaunchd/applaunchd.service4
-rw-r--r--meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb4
2 files changed, 5 insertions, 3 deletions
diff --git a/meta-app-framework/recipes-core/applaunchd/applaunchd/applaunchd.service b/meta-app-framework/recipes-core/applaunchd/applaunchd/applaunchd.service
index a5a2df53a..b4c2b0a22 100644
--- a/meta-app-framework/recipes-core/applaunchd/applaunchd/applaunchd.service
+++ b/meta-app-framework/recipes-core/applaunchd/applaunchd/applaunchd.service
@@ -1,6 +1,6 @@
[Unit]
-Wants=network.target
-After=network.target
+Wants=network.target polkit.service
+After=network.target polkit.service
[Service]
User=applaunchd
diff --git a/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb b/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
index 767c8bcc5..38d89b23f 100644
--- a/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
+++ b/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
@@ -29,7 +29,9 @@ SRCREV = "7a3e870a8349d43a4838604db2c28140c2f76c9f"
S = "${WORKDIR}/git"
-inherit meson pkgconfig systemd useradd
+inherit meson pkgconfig systemd useradd features_check
+
+REQUIRED_DISTRO_FEATURES = "systemd polkit"
USERADD_PACKAGES = "${PN}"
USERADDEXTENSION = "useradd-staticids"