summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/conf/include/agl_qemux86-64.inc13
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf1
-rw-r--r--meta-agl-bsp/wic/directdisk.wks.in9
-rw-r--r--meta-agl-distro/conf/distro/include/x86_64-tune.inc1
-rw-r--r--meta-agl/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_%.bbappend2
-rw-r--r--meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb3
-rw-r--r--meta-security/recipes-core/dbus-cynara/dbus-cynara_1.10.20.bb2
7 files changed, 24 insertions, 7 deletions
diff --git a/meta-agl-bsp/conf/include/agl_qemux86-64.inc b/meta-agl-bsp/conf/include/agl_qemux86-64.inc
index 165deae41..1fe839d68 100644
--- a/meta-agl-bsp/conf/include/agl_qemux86-64.inc
+++ b/meta-agl-bsp/conf/include/agl_qemux86-64.inc
@@ -3,19 +3,19 @@
# To get wide screen than default, there are a selection of resolutions
# available:
#
-#APPEND += "uvesafb.mode_option=1024x768-32"
-APPEND += "uvesafb.mode_option=1280x1024-32"
-#APPEND += "uvesafb.mode_option=1600x1200-32"
+#UVESA_MODE = "1024x768-32"
+UVESA_MODE = "1280x1024-32"
+#UVESA_MODE = "1600x1200-32"
#
# To avoid corrupt boot screen by systemd message, you can use serial
# console separated from VGA console or disable all boot messages by
# kernel command line.
#
# Configuration for serial console
-APPEND += "console=ttyS0,115200n8"
+QB_KERNEL_CMDLINE_APPEND_append = " console=ttyS0,115200n8"
#
# All boot message will be off
-APPEND += "quiet"
+QB_KERNEL_CMDLINE_APPEND_append = " quiet"
# Build updatable image. Only takes effect when sota.bbclass is inherited
DISTRO_FEATURES_append = " sota"
@@ -29,3 +29,6 @@ ROOT_VM = "root=PARTUUID=${DISK_SIGNATURE}-02"
# Force the virtio video device as 'vmware' doesn't always work
QB_OPT_APPEND_append = " -vga virtio"
+
+# Use our own wks file
+WKS_FILE="directdisk.wks.in"
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf b/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
index 1d2acf663..2b1ac5a7e 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
@@ -67,4 +67,5 @@ DISTRO_FEATURES_append = " bluetooth"
BBMASK += "/meta-rcar-gen3-adas/recipes-core/systemd/"
BBMASK += "/meta-rcar-gen3-adas/recipes-graphics/opencv/"
+BBMASK += "/meta-rcar-gen3-adas/recipes-devtools/valgrind/"
diff --git a/meta-agl-bsp/wic/directdisk.wks.in b/meta-agl-bsp/wic/directdisk.wks.in
new file mode 100644
index 000000000..f7b220cdb
--- /dev/null
+++ b/meta-agl-bsp/wic/directdisk.wks.in
@@ -0,0 +1,9 @@
+# short-description: Create a 'pcbios' direct disk image
+# long-description: Creates a partitioned legacy BIOS disk image that the user
+# can directly dd to boot media.
+
+part /boot --source bootimg-pcbios --use-uuid --label boot --active --align 1024
+part / --source rootfs --use-uuid --fstype=ext4 --label platform --align 1024
+
+bootloader --timeout=0 --append="rootwait rootfstype=ext4 ${QB_KERNEL_CMDLINE_APPEND}"
+
diff --git a/meta-agl-distro/conf/distro/include/x86_64-tune.inc b/meta-agl-distro/conf/distro/include/x86_64-tune.inc
index f3bfc372f..2efeca04d 100644
--- a/meta-agl-distro/conf/distro/include/x86_64-tune.inc
+++ b/meta-agl-distro/conf/distro/include/x86_64-tune.inc
@@ -51,6 +51,5 @@ QB_SYSTEM_NAME_x86-64 = "qemu-system-x86_64"
QB_CPU_x86-64 = "-cpu qemu64,+ssse3,+sse4.1,+sse4.2,+popcnt"
QB_CPU_KVM_x86-64 = "-cpu kvm64 -cpu qemu64,+ssse3,+sse4.1,+sse4.2,+popcnt"
-QB_KERNEL_CMDLINE_APPEND = "vga=0 uvesafb.mode_option=1024x768-32 oprofile.timer=1 uvesafb.task_timeout=-1"
# Add the 'virtio-rng-pci' device otherwise the guest may run out of entropy
QB_OPT_APPEND = "-vga vmware -show-cursor -usb -usbdevice tablet -device virtio-rng-pci"
diff --git a/meta-agl/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_%.bbappend b/meta-agl/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_%.bbappend
new file mode 100644
index 000000000..86a181fbb
--- /dev/null
+++ b/meta-agl/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_%.bbappend
@@ -0,0 +1,2 @@
+# libv4l2 is useful for making more efficient use of cameras via v4l2src.
+PACKAGECONFIG_append = " libv4l2"
diff --git a/meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb b/meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb
index 44fabae06..84a951bce 100644
--- a/meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb
+++ b/meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb
@@ -30,13 +30,14 @@ RDEPENDS_${PN} += "\
packagegroup-ivi-common-test-ltp \
rt-tests \
stress \
- trinity \
"
# to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
# netperf
# FTBS, SPEC-316
# himeno
+# FTBS, SPEC-1384
+# trinity
# Packages for shell commands which are required by LTP
diff --git a/meta-security/recipes-core/dbus-cynara/dbus-cynara_1.10.20.bb b/meta-security/recipes-core/dbus-cynara/dbus-cynara_1.10.20.bb
index c46298e53..a97148366 100644
--- a/meta-security/recipes-core/dbus-cynara/dbus-cynara_1.10.20.bb
+++ b/meta-security/recipes-core/dbus-cynara/dbus-cynara_1.10.20.bb
@@ -12,6 +12,8 @@ SRC_URI_append = "\
"
DEPENDS += "cynara smack"
+RDEPENDS_${PN} += "dbus"
+
EXTRA_OECONF += "--enable-cynara --disable-selinux"
inherit distro_features_check