summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/conf/include/agl_cubox-i.inc22
-rw-r--r--meta-agl-bsp/conf/include/agl_nitrogen6x.inc17
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend5
-rw-r--r--templates/machine/cubox-i/40_bblayers.conf.inc6
-rw-r--r--templates/machine/cubox-i/50_local.conf.inc4
-rw-r--r--templates/machine/cubox-i/50_setup.sh2
-rw-r--r--templates/machine/nitrogen6x/40_bblayers.conf.inc6
-rw-r--r--templates/machine/nitrogen6x/50_local.conf.inc3
-rw-r--r--templates/machine/nitrogen6x/50_setup.sh2
9 files changed, 67 insertions, 0 deletions
diff --git a/meta-agl-bsp/conf/include/agl_cubox-i.inc b/meta-agl-bsp/conf/include/agl_cubox-i.inc
new file mode 100644
index 000000000..a82c27cc1
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_cubox-i.inc
@@ -0,0 +1,22 @@
+DISTRO_FEATURES_append = " agl-medium-arm-compiler"
+
+# This disables the Freescale/NXP Vivante GPU driver and enables
+# etnaviv support.
+MACHINEOVERRIDES .= ":use-mainline-bsp"
+
+# Include devicetrees for SOM 1.5 and Hummingboard 2 hardware
+KERNEL_DEVICETREE_append = " \
+ imx6dl-hummingboard-som-v15.dtb imx6q-hummingboard-som-v15.dtb \
+ imx6dl-hummingboard2.dtb imx6q-hummingboard2.dtb \
+ imx6dl-hummingboard2-som-v15.dtb imx6q-hummingboard2-som-v15.dtb \
+"
+
+# Disable the meta-freescale weston-init bbappend as it conflicts
+# with AGL's.
+BBMASK = "meta-freescale/recipes-graphics/wayland/weston-init"
+
+# Set CMA size large enough to work with AGL
+UBOOT_EXTLINUX_KERNEL_ARGS_append = " cma=512M"
+
+# Generate WIC image also
+AGL_EXTRA_IMAGE_FSTYPES = "wic.xz wic.bmap wic.xz.sha256sum"
diff --git a/meta-agl-bsp/conf/include/agl_nitrogen6x.inc b/meta-agl-bsp/conf/include/agl_nitrogen6x.inc
new file mode 100644
index 000000000..782e618a2
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_nitrogen6x.inc
@@ -0,0 +1,17 @@
+DISTRO_FEATURES_append = " agl-medium-arm-compiler"
+
+# This disables the Freescale/NXP Vivante GPU driver and enables
+# etnaviv support.
+MACHINEOVERRIDES .= ":use-mainline-bsp"
+
+# Disable the meta-freescale weston-init bbappend as it conflicts
+# with AGL's.
+BBMASK = "meta-freescale/recipes-graphics/wayland/weston-init"
+
+# Set CMA size large enough to work with AGL
+UBOOT_EXTLINUX_KERNEL_ARGS_append = " cma=512M"
+
+# Generate WIC image also
+#WKS_FILE = "imx-uboot.wks"
+AGL_EXTRA_IMAGE_FSTYPES = "wic.xz wic.bmap wic.xz.sha256sum"
+AGL_DEFAULT_INITRAMFS_FSTYPES := ""
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend
index 4fa422136..640f9cfe5 100644
--- a/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend
@@ -18,3 +18,8 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/cfg80211.cfg"
# (lock debugging and userspace firmware loader fallback)
SRC_URI_append = " file://fixups.cfg"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/fixups.cfg"
+
+do_install_append_cubox-i() {
+ # Add symlink to work with default Hummingboard 2 u-boot configuration
+ ln -sf imx6q-hummingboard2.dtb ${D}/boot/imx6q-hummingboard2-emmc.dtb
+}
diff --git a/templates/machine/cubox-i/40_bblayers.conf.inc b/templates/machine/cubox-i/40_bblayers.conf.inc
new file mode 100644
index 000000000..a4323be1a
--- /dev/null
+++ b/templates/machine/cubox-i/40_bblayers.conf.inc
@@ -0,0 +1,6 @@
+# This must be parsed after qt5, etc. layers so that they are correctly
+# recognized by meta-freescale/dynamic-layers
+BBLAYERS =+ "\
+ ${METADIR}/bsp/meta-freescale \
+ ${METADIR}/bsp/meta-freescale-3rdparty \
+ "
diff --git a/templates/machine/cubox-i/50_local.conf.inc b/templates/machine/cubox-i/50_local.conf.inc
new file mode 100644
index 000000000..b0835bf6e
--- /dev/null
+++ b/templates/machine/cubox-i/50_local.conf.inc
@@ -0,0 +1,4 @@
+MACHINE = "cubox-i"
+#see meta-agl/meta-agl-bsp/conf/include/agl_cubox-i.inc
+require conf/include/agl_cubox-i.inc
+
diff --git a/templates/machine/cubox-i/50_setup.sh b/templates/machine/cubox-i/50_setup.sh
new file mode 100644
index 000000000..bb22790dc
--- /dev/null
+++ b/templates/machine/cubox-i/50_setup.sh
@@ -0,0 +1,2 @@
+find_and_ack_eula $METADIR/meta-freescale EULA
+export EULA_FLAG_NAME="ACCEPT_FSL_EULA"
diff --git a/templates/machine/nitrogen6x/40_bblayers.conf.inc b/templates/machine/nitrogen6x/40_bblayers.conf.inc
new file mode 100644
index 000000000..a4323be1a
--- /dev/null
+++ b/templates/machine/nitrogen6x/40_bblayers.conf.inc
@@ -0,0 +1,6 @@
+# This must be parsed after qt5, etc. layers so that they are correctly
+# recognized by meta-freescale/dynamic-layers
+BBLAYERS =+ "\
+ ${METADIR}/bsp/meta-freescale \
+ ${METADIR}/bsp/meta-freescale-3rdparty \
+ "
diff --git a/templates/machine/nitrogen6x/50_local.conf.inc b/templates/machine/nitrogen6x/50_local.conf.inc
new file mode 100644
index 000000000..f8178bbd1
--- /dev/null
+++ b/templates/machine/nitrogen6x/50_local.conf.inc
@@ -0,0 +1,3 @@
+MACHINE = "nitrogen6x"
+#see meta-agl/meta-agl-bsp/conf/include/agl_nitrogen6x.inc
+require conf/include/agl_nitrogen6x.inc
diff --git a/templates/machine/nitrogen6x/50_setup.sh b/templates/machine/nitrogen6x/50_setup.sh
new file mode 100644
index 000000000..bb22790dc
--- /dev/null
+++ b/templates/machine/nitrogen6x/50_setup.sh
@@ -0,0 +1,2 @@
+find_and_ack_eula $METADIR/meta-freescale EULA
+export EULA_FLAG_NAME="ACCEPT_FSL_EULA"