summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/conf/include/agl_h3-salvator-x.inc3
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-mmngr/kernel-module-mmngr.bbappend3
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-mmngr/kernel-module-mmngrbuf.bbappend3
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-vspmif/kernel-module-vspmif.bbappend3
-rw-r--r--meta-agl-distro/conf/distro/poky-agl.conf9
-rw-r--r--meta-agl/recipes-devtools/gdb/gdb_%.bbappend1
-rw-r--r--meta-app-framework/recipes-apps/low-level-can-service/low-level-can-service_git.bb2
-rw-r--r--meta-app-framework/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default6
-rw-r--r--meta-app-framework/recipes-config/dev-mapping/dev-mapping_0.1.bb18
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension/0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch31
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb1
-rwxr-xr-xscripts/mkabl-agl.sh2
-rw-r--r--templates/machine/h3-salvator-x/50_bblayers.conf.inc3
-rw-r--r--templates/machine/h3-salvator-x/50_local.conf.inc4
-rw-r--r--templates/machine/h3-salvator-x/50_setup.sh10
15 files changed, 95 insertions, 4 deletions
diff --git a/meta-agl-bsp/conf/include/agl_h3-salvator-x.inc b/meta-agl-bsp/conf/include/agl_h3-salvator-x.inc
new file mode 100644
index 000000000..74036111d
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_h3-salvator-x.inc
@@ -0,0 +1,3 @@
+# The H3-based (as opposed to the M3-based version) salvator-x needs a different
+# MACHINE but otherwise uses the same config as the H3.
+require conf/include/agl_h3ulcb.inc
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-mmngr/kernel-module-mmngr.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-mmngr/kernel-module-mmngr.bbappend
index 13163e495..5262a9c5d 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-mmngr/kernel-module-mmngr.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-mmngr/kernel-module-mmngr.bbappend
@@ -1 +1,2 @@
-KERNEL_MODULE_AUTOLOAD = "mmngr"
+KERNEL_MODULE_AUTOLOAD_append = " mmngr"
+KERNEL_MODULE_PACKAGE_SUFFIX = ""
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-mmngr/kernel-module-mmngrbuf.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-mmngr/kernel-module-mmngrbuf.bbappend
index 1587b25b6..6b935b09e 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-mmngr/kernel-module-mmngrbuf.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-mmngr/kernel-module-mmngrbuf.bbappend
@@ -1 +1,2 @@
-KERNEL_MODULE_AUTOLOAD = "mmngrbuf"
+KERNEL_MODULE_AUTOLOAD_append = " mmngrbuf"
+KERNEL_MODULE_PACKAGE_SUFFIX = ""
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-vspmif/kernel-module-vspmif.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-vspmif/kernel-module-vspmif.bbappend
index 098e1b0a9..379797248 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-vspmif/kernel-module-vspmif.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-vspmif/kernel-module-vspmif.bbappend
@@ -1 +1,2 @@
-KERNEL_MODULE_AUTOLOAD = "vspm_if"
+KERNEL_MODULE_AUTOLOAD_append = " vspm_if"
+KERNEL_MODULE_PACKAGE_SUFFIX = ""
diff --git a/meta-agl-distro/conf/distro/poky-agl.conf b/meta-agl-distro/conf/distro/poky-agl.conf
index 078951703..d79111742 100644
--- a/meta-agl-distro/conf/distro/poky-agl.conf
+++ b/meta-agl-distro/conf/distro/poky-agl.conf
@@ -80,6 +80,15 @@ PREFERRED_VERSION_gstreamer1.0-omx ?= "1.2.%"
# Prefer libjpeg-turbo
PREFERRED_PROVIDER_jpeg = "libjpeg-turbo"
+# GPLv3 Compliance
+PREFERRED_VERSION_bash = "3.2.%"
+PREFERRED_VERSION_gawk = "3.1.%"
+#PREFERRED_VERSION_gdbm = "1.8.%"
+PREFERRED_VERSION_gnupg = "1.4.7"
+PREFERRED_VERSION_gnutls = "3.3.%"
+PREFERRED_VERSION_mc = "4.7.5.%"
+PREFERRED_VERSION_readline = "5.2"
+
# using multiple BSP layers causes dangling bbappends in meta-agl-bsp
# turn it into a warning
#BB_DANGLINGAPPENDS_WARNONLY = "1"
diff --git a/meta-agl/recipes-devtools/gdb/gdb_%.bbappend b/meta-agl/recipes-devtools/gdb/gdb_%.bbappend
new file mode 100644
index 000000000..7cba933af
--- /dev/null
+++ b/meta-agl/recipes-devtools/gdb/gdb_%.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG_remove = "readline"
diff --git a/meta-app-framework/recipes-apps/low-level-can-service/low-level-can-service_git.bb b/meta-app-framework/recipes-apps/low-level-can-service/low-level-can-service_git.bb
index 8ba440192..78d96e928 100644
--- a/meta-app-framework/recipes-apps/low-level-can-service/low-level-can-service_git.bb
+++ b/meta-app-framework/recipes-apps/low-level-can-service/low-level-can-service_git.bb
@@ -12,5 +12,7 @@ SRCREV = "d8d990528ea9746b21788f97be3fdbcc392c5d96"
PV = "5.0+git${SRCPV}"
S = "${WORKDIR}/git"
+RDEPENDS_${PN} = "dev-mapping"
+
inherit cmake aglwgt pkgconfig
diff --git a/meta-app-framework/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default b/meta-app-framework/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default
new file mode 100644
index 000000000..7bd8bf2eb
--- /dev/null
+++ b/meta-app-framework/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default
@@ -0,0 +1,6 @@
+; Default CAN device mapping
+; Format has to follow ini rules key="value", notice " around value.
+
+[CANbus-mapping]
+hs="can0"
+ls="can0"
diff --git a/meta-app-framework/recipes-config/dev-mapping/dev-mapping_0.1.bb b/meta-app-framework/recipes-config/dev-mapping/dev-mapping_0.1.bb
new file mode 100644
index 000000000..befb5443f
--- /dev/null
+++ b/meta-app-framework/recipes-config/dev-mapping/dev-mapping_0.1.bb
@@ -0,0 +1,18 @@
+inherit allarch
+
+SUMMARY = "AGL Device mapping configuration file"
+DESCRIPTION = "This provide default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in low-can binding by example."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://dev-mapping.conf.default"
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/dev-mapping.conf.default ${D}${sysconfdir}/dev-mapping.conf
+}
diff --git a/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension/0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension/0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch
new file mode 100644
index 000000000..636ecf1b9
--- /dev/null
+++ b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension/0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch
@@ -0,0 +1,31 @@
+From 97af4843a4705cd7d5b6b69abb9002fd974a5b94 Mon Sep 17 00:00:00 2001
+From: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
+Date: Fri, 12 Jan 2018 01:53:01 +0900
+Subject: [PATCH] Resolve weston cursh when repeat touching very quickly
+
+Weston sometimes crush while the user repeat touching very
+quickly icons/shortcuts on HomeScreen.
+
+Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
+---
+ ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c b/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
+index b0fe37d..f1a31d0 100644
+--- a/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
++++ b/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
+@@ -557,6 +557,10 @@ touch_grab_up(struct weston_touch_grab *grab, uint32_t time, int touch_id)
+ const struct ivi_layout_interface *interface =
+ seat->input_ctx->ivi_layout_interface;
+
++ /* if touch device has no focused view, there is nothing to do*/
++ if (grab->touch->focus == NULL)
++ return;
++
+ /* For each surface_ctx, check for focus and send */
+ wl_list_for_each(surf_ctx, &seat->input_ctx->surface_list, link) {
+ struct weston_surface *surf, *send_surf;
+--
+2.7.4
+
diff --git a/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb
index e20132cab..68e92adb5 100644
--- a/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb
+++ b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb
@@ -10,6 +10,7 @@ SRC_URI = "git://github.com/GENIVI/${BPN}.git;protocol=http \
file://0001-simple-id-agent-initial-commit.patch;patch=1 \
file://0002-ivi-controller-load-id-agent-module.patch;patch=1 \
file://0003-ivi-controller-add-resize-setting-suit-to-surface-si.patch \
+ file://0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch \
"
S = "${WORKDIR}/git"
diff --git a/scripts/mkabl-agl.sh b/scripts/mkabl-agl.sh
index a3d9ae37e..8483d231d 100755
--- a/scripts/mkabl-agl.sh
+++ b/scripts/mkabl-agl.sh
@@ -451,7 +451,7 @@ if [ -f $HDDIMG_MNT/bzimage ]; then
debug "kernel is bzimage -> vmlinuz"
fi
if [ -f $HDDIMG_MNT/microcode.cpio ]; then
- die "initrd=microcode.cpio is not a supported configuration, change ycoto configuration or use an hddimg as source"
+ warn "initrd=microcode.cpio is not a supported configuration, microcode.cpio has been ignored"
fi
[ -z $KERNEL_TYPE ] && die "Linux kernel type in $HDDIMG is unsupported"
diff --git a/templates/machine/h3-salvator-x/50_bblayers.conf.inc b/templates/machine/h3-salvator-x/50_bblayers.conf.inc
new file mode 100644
index 000000000..b58989c6f
--- /dev/null
+++ b/templates/machine/h3-salvator-x/50_bblayers.conf.inc
@@ -0,0 +1,3 @@
+BBLAYERS =+ "\
+ ${METADIR}/meta-renesas-rcar-gen3/meta-rcar-gen3 \
+ "
diff --git a/templates/machine/h3-salvator-x/50_local.conf.inc b/templates/machine/h3-salvator-x/50_local.conf.inc
new file mode 100644
index 000000000..05cca9743
--- /dev/null
+++ b/templates/machine/h3-salvator-x/50_local.conf.inc
@@ -0,0 +1,4 @@
+MACHINE = "salvator-x"
+#see meta-agl/meta-agl-bsp/conf/include/agl_h3-salvator-x.inc
+require conf/include/agl_h3-salvator-x.inc
+
diff --git a/templates/machine/h3-salvator-x/50_setup.sh b/templates/machine/h3-salvator-x/50_setup.sh
new file mode 100644
index 000000000..abd2a33af
--- /dev/null
+++ b/templates/machine/h3-salvator-x/50_setup.sh
@@ -0,0 +1,10 @@
+# setup proprietary gfx drivers and multimedia packages
+pushd $METADIR 2>/dev/null
+
+SETUP_MM_SCRIPT=$METADIR/meta-agl/meta-agl-bsp/meta-rcar-gen3/scripts/setup_mm_packages.sh
+if [ -f $SETUP_MM_SCRIPT ]; then
+ . $SETUP_MM_SCRIPT
+ copy_mm_packages
+fi
+
+popd 2>/dev/null