summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/conf/include/agl_intel-corei7-64.inc3
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend (renamed from meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.9%.bbappend)2
l---------meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.9%.bbappend1
-rw-r--r--meta-agl/recipes-core/packagegroups/packagegroup-core-boot-agl.bb1
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb19
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc2
-rw-r--r--templates/feature/agl-all-features/included.dep2
-rw-r--r--templates/feature/agl-ci-change-features/included.dep2
-rw-r--r--templates/feature/agl-ci-snapshot-features-nogfx/included.dep2
-rw-r--r--templates/feature/agl-ci-snapshot-features/included.dep2
10 files changed, 26 insertions, 10 deletions
diff --git a/meta-agl-bsp/conf/include/agl_intel-corei7-64.inc b/meta-agl-bsp/conf/include/agl_intel-corei7-64.inc
index cc181ddaa..534d36475 100644
--- a/meta-agl-bsp/conf/include/agl_intel-corei7-64.inc
+++ b/meta-agl-bsp/conf/include/agl_intel-corei7-64.inc
@@ -11,3 +11,6 @@ INITRD_LIVE = "${DEPLOY_DIR_IMAGE}/${INITRD_IMAGE_LIVE}-${MACHINE}.ext4.gz"
# Modify this file under meta-agl-bsp/meta-intel/wic to change the
# kernel command line, including to change the screen resolution.
WKS_FILE = "systemd-intel-corei7-64-bootdisk.wks"
+
+PREFERRED_VERSION_linux-intel ?= "4.14%"
+PREFERRED_VERSION_linux-intel-rt ?= "4.14%"
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.9%.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
index 7f249f207..c49b8ecb0 100644
--- a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.9%.bbappend
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.14%.bbappend
@@ -1,7 +1,5 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-require recipes-kernel/linux/linux-agl-4.9.inc
-
# adding most supported USB Bluetooth, Wifi, and Ethernet devices
SRC_URI_append = " file://usb-devices.cfg"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.9%.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.9%.bbappend
deleted file mode 120000
index 323cbe55a..000000000
--- a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.9%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-linux-intel_4.9%.bbappend \ No newline at end of file
diff --git a/meta-agl/recipes-core/packagegroups/packagegroup-core-boot-agl.bb b/meta-agl/recipes-core/packagegroups/packagegroup-core-boot-agl.bb
index 0d877896f..c9d679879 100644
--- a/meta-agl/recipes-core/packagegroups/packagegroup-core-boot-agl.bb
+++ b/meta-agl/recipes-core/packagegroups/packagegroup-core-boot-agl.bb
@@ -45,5 +45,6 @@ RDEPENDS_${PN} = "\
${MACHINE_ESSENTIAL_EXTRA_RDEPENDS}"
RRECOMMENDS_${PN} = "\
+ tzdata \
${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS}"
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
index 1850e2bd8..91f26b894 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
@@ -4,12 +4,27 @@ DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
inherit cmake pkgconfig
-EXTRA_OECMAKE_append_agl-devel = " -DAGL_DEVEL=ON -DINCLUDE_MONITORING=ON"
+EXTRA_OECMAKE_append_class-target = "\
+ -DUNITDIR_SYSTEM=${systemd_system_unitdir} \
+"
+
+EXTRA_OECMAKE_append_agl-devel = " \
+ -DAGL_DEVEL=ON \
+ -DINCLUDE_MONITORING=ON \
+ -DINCLUDE_SUPERVISOR=ON -DAFS_SURPERVISION_SOCKET=/run/platform/supervisor \
+"
pkg_postinst_${PN}() {
mkdir -p "$D${libdir}/afb"
}
+do_install_append_agl-devel_class-target() {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -d -m 0755 ${D}${systemd_system_unitdir}/multi-user.target.wants
+ ln -s ../afs-supervisor.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afs-supervisor.service
+ fi
+}
+
#############################################
# setup package
#############################################
@@ -17,7 +32,7 @@ PACKAGES =+ "${PN}-tools ${PN}-devtools ${PN}-meta"
FILES_${PN} += "${datadir}"
-FILES_${PN}_append_agl-devel = " ${libdir}/afb/monitoring"
+FILES_${PN}_append_agl-devel = " ${libdir}/afb/monitoring ${systemd_system_unitdir}"
ALLOW_EMPTY_${PN}-meta = "1"
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc
index ac55b5f02..48123c0b4 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "9c1c9a1ba46eb9ddada4167ce9d20143ee3c9636"
+SRCREV = "bd10bc4405f3777fe495cb9f62818d67ab584854"
PV = "${AGL_BRANCH}+git${SRCPV}"
S = "${WORKDIR}/git"
diff --git a/templates/feature/agl-all-features/included.dep b/templates/feature/agl-all-features/included.dep
index 70751f350..80717ded0 100644
--- a/templates/feature/agl-all-features/included.dep
+++ b/templates/feature/agl-all-features/included.dep
@@ -1 +1 @@
-agl-demo agl-netboot agl-sota agl-sdl
+agl-demo agl-netboot
diff --git a/templates/feature/agl-ci-change-features/included.dep b/templates/feature/agl-ci-change-features/included.dep
index 10ab12bb3..fdd01e6a8 100644
--- a/templates/feature/agl-ci-change-features/included.dep
+++ b/templates/feature/agl-ci-change-features/included.dep
@@ -1 +1 @@
-agl-demo agl-devel agl-netboot agl-appfw-smack agl-sdl
+agl-demo agl-devel agl-netboot agl-appfw-smack
diff --git a/templates/feature/agl-ci-snapshot-features-nogfx/included.dep b/templates/feature/agl-ci-snapshot-features-nogfx/included.dep
index ba9820a46..00e77831a 100644
--- a/templates/feature/agl-ci-snapshot-features-nogfx/included.dep
+++ b/templates/feature/agl-ci-snapshot-features-nogfx/included.dep
@@ -1 +1 @@
-agl-devel agl-netboot agl-appfw-smack agl-isafw agl-archiver agl-ptest
+agl-devel agl-netboot agl-appfw-smack agl-archiver
diff --git a/templates/feature/agl-ci-snapshot-features/included.dep b/templates/feature/agl-ci-snapshot-features/included.dep
index b09eff04b..219beeec4 100644
--- a/templates/feature/agl-ci-snapshot-features/included.dep
+++ b/templates/feature/agl-ci-snapshot-features/included.dep
@@ -1 +1 @@
-agl-demo agl-devel agl-netboot agl-appfw-smack agl-archiver agl-sdl agl-ptest
+agl-demo agl-devel agl-netboot agl-appfw-smack agl-archiver