summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-agl-bsp/conf/include/agl_h3-salvator-x.inc3
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/scripts/setup_mm_packages.sh50
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension/0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch31
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb1
-rwxr-xr-xscripts/mkabl-agl.sh2
-rw-r--r--templates/machine/h3-salvator-x/50_bblayers.conf.inc3
-rw-r--r--templates/machine/h3-salvator-x/50_local.conf.inc4
-rw-r--r--templates/machine/h3-salvator-x/50_setup.sh10
8 files changed, 78 insertions, 26 deletions
diff --git a/meta-agl-bsp/conf/include/agl_h3-salvator-x.inc b/meta-agl-bsp/conf/include/agl_h3-salvator-x.inc
new file mode 100644
index 000000000..74036111d
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_h3-salvator-x.inc
@@ -0,0 +1,3 @@
+# The H3-based (as opposed to the M3-based version) salvator-x needs a different
+# MACHINE but otherwise uses the same config as the H3.
+require conf/include/agl_h3ulcb.inc
diff --git a/meta-agl-bsp/meta-rcar-gen3/scripts/setup_mm_packages.sh b/meta-agl-bsp/meta-rcar-gen3/scripts/setup_mm_packages.sh
index 242c0f0d5..dddb3379c 100644
--- a/meta-agl-bsp/meta-rcar-gen3/scripts/setup_mm_packages.sh
+++ b/meta-agl-bsp/meta-rcar-gen3/scripts/setup_mm_packages.sh
@@ -35,30 +35,30 @@ function log() {
}
function copy_mm_packages() {
- if [ -f $DOWNLOAD_DIR/$ZIP_1 -a -f $DOWNLOAD_DIR/$ZIP_2 ]; then
- mkdir -p $EXTRACT_DIR
- cp --update $DOWNLOAD_DIR/$ZIP_1 $EXTRACT_DIR
- cp --update $DOWNLOAD_DIR/$ZIP_2 $EXTRACT_DIR
- else
- error "ERROR: FILES \""+$DOWNLOAD_DIR/$ZIP_1+"\" NOT EXTRACTING CORRECTLY"
- error "ERROR: FILES \""+$DOWNLOAD_DIR/$ZIP_2+"\" NOT EXTRACTING CORRECTLY"
- log "The graphics and multimedia acceleration packages for "
- log "the R-Car Gen3 board BSP 2.19 can be downloaded from:"
- log " <https://www.renesas.com/en-us/solutions/automotive/rcar-demoboard-2.html>"
- log
- error "These 2 files from there should be stored in your"
- error "'$DOWNLOAD_DIR' directory."
- error " $ZIP_1"
- error " $ZIP_2"
- return 1
- fi
+ if [ -f $DOWNLOAD_DIR/$ZIP_1 -a -f $DOWNLOAD_DIR/$ZIP_2 ]; then
+ mkdir -p $EXTRACT_DIR
+ cp --update $DOWNLOAD_DIR/$ZIP_1 $EXTRACT_DIR
+ cp --update $DOWNLOAD_DIR/$ZIP_2 $EXTRACT_DIR
+ else
+ error "ERROR: FILES \""+$DOWNLOAD_DIR/$ZIP_1+"\" NOT EXTRACTING CORRECTLY"
+ error "ERROR: FILES \""+$DOWNLOAD_DIR/$ZIP_2+"\" NOT EXTRACTING CORRECTLY"
+ log "The graphics and multimedia acceleration packages for "
+ log "the R-Car Gen3 board BSP can be downloaded from:"
+ log "<https://www.renesas.com/en-us/solutions/automotive/rcar-demoboard-2.html>"
+ log
+ error "These 2 files from there should be stored in your"
+ error "'$DOWNLOAD_DIR' directory."
+ error " $ZIP_1"
+ error " $ZIP_2"
+ return 1
+ fi
- if [ -f $COPY_SCRIPT ]; then
- cd $METADIR/meta-renesas-rcar-gen3/
- $COPY_SCRIPT -d -f $EXTRACT_DIR
- cd ..
- else
- log "scripts to copy drivers for Gen3 not found."
- return 1
- fi
+ if [ -f $COPY_SCRIPT ]; then
+ cd $METADIR/meta-renesas-rcar-gen3/
+ $COPY_SCRIPT -d -f $EXTRACT_DIR
+ cd ..
+ else
+ log "scripts to copy drivers for Gen3 not found."
+ return 1
+ fi
}
diff --git a/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension/0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension/0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch
new file mode 100644
index 000000000..636ecf1b9
--- /dev/null
+++ b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension/0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch
@@ -0,0 +1,31 @@
+From 97af4843a4705cd7d5b6b69abb9002fd974a5b94 Mon Sep 17 00:00:00 2001
+From: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
+Date: Fri, 12 Jan 2018 01:53:01 +0900
+Subject: [PATCH] Resolve weston cursh when repeat touching very quickly
+
+Weston sometimes crush while the user repeat touching very
+quickly icons/shortcuts on HomeScreen.
+
+Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
+---
+ ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c b/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
+index b0fe37d..f1a31d0 100644
+--- a/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
++++ b/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
+@@ -557,6 +557,10 @@ touch_grab_up(struct weston_touch_grab *grab, uint32_t time, int touch_id)
+ const struct ivi_layout_interface *interface =
+ seat->input_ctx->ivi_layout_interface;
+
++ /* if touch device has no focused view, there is nothing to do*/
++ if (grab->touch->focus == NULL)
++ return;
++
+ /* For each surface_ctx, check for focus and send */
+ wl_list_for_each(surf_ctx, &seat->input_ctx->surface_list, link) {
+ struct weston_surface *surf, *send_surf;
+--
+2.7.4
+
diff --git a/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb
index e20132cab..68e92adb5 100644
--- a/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb
+++ b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.13.0.bb
@@ -10,6 +10,7 @@ SRC_URI = "git://github.com/GENIVI/${BPN}.git;protocol=http \
file://0001-simple-id-agent-initial-commit.patch;patch=1 \
file://0002-ivi-controller-load-id-agent-module.patch;patch=1 \
file://0003-ivi-controller-add-resize-setting-suit-to-surface-si.patch \
+ file://0001-Resolve-weston-crush-when-repeat-touching-very-quick.patch \
"
S = "${WORKDIR}/git"
diff --git a/scripts/mkabl-agl.sh b/scripts/mkabl-agl.sh
index a3d9ae37e..8483d231d 100755
--- a/scripts/mkabl-agl.sh
+++ b/scripts/mkabl-agl.sh
@@ -451,7 +451,7 @@ if [ -f $HDDIMG_MNT/bzimage ]; then
debug "kernel is bzimage -> vmlinuz"
fi
if [ -f $HDDIMG_MNT/microcode.cpio ]; then
- die "initrd=microcode.cpio is not a supported configuration, change ycoto configuration or use an hddimg as source"
+ warn "initrd=microcode.cpio is not a supported configuration, microcode.cpio has been ignored"
fi
[ -z $KERNEL_TYPE ] && die "Linux kernel type in $HDDIMG is unsupported"
diff --git a/templates/machine/h3-salvator-x/50_bblayers.conf.inc b/templates/machine/h3-salvator-x/50_bblayers.conf.inc
new file mode 100644
index 000000000..b58989c6f
--- /dev/null
+++ b/templates/machine/h3-salvator-x/50_bblayers.conf.inc
@@ -0,0 +1,3 @@
+BBLAYERS =+ "\
+ ${METADIR}/meta-renesas-rcar-gen3/meta-rcar-gen3 \
+ "
diff --git a/templates/machine/h3-salvator-x/50_local.conf.inc b/templates/machine/h3-salvator-x/50_local.conf.inc
new file mode 100644
index 000000000..05cca9743
--- /dev/null
+++ b/templates/machine/h3-salvator-x/50_local.conf.inc
@@ -0,0 +1,4 @@
+MACHINE = "salvator-x"
+#see meta-agl/meta-agl-bsp/conf/include/agl_h3-salvator-x.inc
+require conf/include/agl_h3-salvator-x.inc
+
diff --git a/templates/machine/h3-salvator-x/50_setup.sh b/templates/machine/h3-salvator-x/50_setup.sh
new file mode 100644
index 000000000..abd2a33af
--- /dev/null
+++ b/templates/machine/h3-salvator-x/50_setup.sh
@@ -0,0 +1,10 @@
+# setup proprietary gfx drivers and multimedia packages
+pushd $METADIR 2>/dev/null
+
+SETUP_MM_SCRIPT=$METADIR/meta-agl/meta-agl-bsp/meta-rcar-gen3/scripts/setup_mm_packages.sh
+if [ -f $SETUP_MM_SCRIPT ]; then
+ . $SETUP_MM_SCRIPT
+ copy_mm_packages
+fi
+
+popd 2>/dev/null