summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb')
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb b/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb
index 798fcebe6..df8f62937 100644
--- a/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb
@@ -8,6 +8,9 @@ SRC_URI = "file://hci-uart-helper.service \
file://hci-uart-helper.sh \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
COMPATIBLE_MACHINE = "imx8mq-evk"
do_configure[noexec] = "1"
@@ -16,11 +19,11 @@ do_compile[noexec] = "1"
do_install() {
# Install helper script
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/hci-uart-helper.sh ${D}${sbindir}/
+ install -m 0755 ${UNPACKDIR}/hci-uart-helper.sh ${D}${sbindir}/
# Install systemd unit
install -d ${D}${systemd_system_unitdir}/
- install -m 0644 ${WORKDIR}/hci-uart-helper.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${UNPACKDIR}/hci-uart-helper.service ${D}${systemd_system_unitdir}/
install -d ${D}${systemd_system_unitdir}/bluetooth.service.wants
ln -s ../hci-uart-helper.service ${D}${systemd_system_unitdir}/bluetooth.service.wants/
}