summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb')
-rw-r--r--meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb b/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
index a3f67004e..a4719280b 100644
--- a/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
+++ b/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
@@ -5,7 +5,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=acc7a1bf87c055789657b148939e4b40"
SRC_URI = "\
- git://github.com/aws/aws-iot-device-sdk-embedded-C.git;protocol=https \
+ git://github.com/aws/aws-iot-device-sdk-embedded-C.git;protocol=https;branch=master \
file://Makefile.aws \
file://aws_iot_config.h \
file://awsiotsdk.pc \
@@ -16,9 +16,9 @@ S = "${WORKDIR}/git"
B = "${WORKDIR}/build"
DEPENDS = "mbedtls"
-RDEPENDS_${PN} += "mbedtls"
+RDEPENDS:${PN} += "mbedtls"
-do_configure_prepend() {
+do_configure:prepend() {
cp ${WORKDIR}/Makefile.aws ${S}/src
cp ${WORKDIR}/aws_iot_config.h ${S}/include
cp ${WORKDIR}/awsiotsdk.pc ${S}
@@ -36,5 +36,5 @@ do_install() {
BBCLASSEXTEND = "native nativesdk"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"