summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-qcom
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-qcom')
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.11.bb (renamed from meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.7.bb)9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.7.bb b/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.11.bb
index 36a983198..5c3583526 100644
--- a/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.7.bb
+++ b/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.11.bb
@@ -5,16 +5,18 @@ SECTION = "devel"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-SRCREV = "193f355823d9dc38f370759153ac950a2833b0e2"
+SRCREV = "395b5994a5fa52f9db10f480fce74e9acdbe3318"
SRC_URI = "git://github.com/96boards/96boards-tools;branch=master;protocol=https"
S = "${WORKDIR}/git"
-inherit systemd allarch
+inherit systemd allarch update-rc.d
do_install () {
install -d ${D}${sysconfdir}/udev/rules.d
install -m 0755 ${S}/*.rules ${D}${sysconfdir}/udev/rules.d/
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${S}/resize-disk ${D}${sysconfdir}/init.d/
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${S}/resize-helper.service ${D}${systemd_unitdir}/system
@@ -23,5 +25,8 @@ do_install () {
install -m 0755 ${S}/resize-helper ${D}${sbindir}
}
+INITSCRIPT_NAME = "resize-disk"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
+
SYSTEMD_SERVICE_${PN} = "resize-helper.service"
RDEPENDS_${PN} += "e2fsprogs-resize2fs gptfdisk parted util-linux udev"