summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot_xen.cmd45
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend18
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb32
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr3
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.cma.txt21
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt21
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb10
7 files changed, 5 insertions, 145 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot_xen.cmd b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot_xen.cmd
deleted file mode 100644
index 24cfb1658..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/files/boot_xen.cmd
+++ /dev/null
@@ -1,45 +0,0 @@
-#
-# SPDX-License-Identifier: MIT
-#
-# Copyright (c) 2020, MERA
-#
-# Author: Leonid Lazarev
-#
-# Xen Boot Script
-#
-# https://www.raspberrypi.org/documentation/configuration/device-tree.md
-# We do not set fdt_addr, because device tree initially is loaded by raspberry pi firmware loader and the particular
-# modification are performed. The prepared DTS is propagated to u-boot and this prepared device tree has to be reused.
-
-setenv kernel_addr_r 0x00480000 # 16M
-setenv xen_addr_r 0x00200000 # 2M
-
-# Load xen to ${xen_addr_r}.
-fatload mmc 0:1 ${xen_addr_r} /xen-@@MACHINE@@
-
-#configure dom0
-fdt addr ${fdt_addr}
-
-#read prepared bootargs, rapsberry pi prepared initial list of the parameters for loading
-fdt get value bootargs /chosen bootargs
-fdt resize 8192
-
-# add device type for raspberry
-fdt set pcie0 device_type "pci"
-
-fdt chosen
-fdt set /chosen \#address-cells <1>
-fdt set /chosen \#size-cells <1>
-
-# Load Linux Image to ${kernel_addr_r}
-fatload mmc 0:1 ${kernel_addr_r} /@@KERNEL_IMAGETYPE@@
-
-# we load dom0 with 1512 MB of memory
-fdt mknod /chosen dom0
-fdt set /chosen xen,xen-bootargs "console=dtuart dtuart=/soc/serial@7e215040 sync_console dom0_mem=1512M bootscrub=0"
-fdt set /chosen xen,dom0-bootargs "${bootargs}"
-
-fdt set /chosen/dom0 compatible "xen,linux-zimage", "xen,multiboot-module"
-fdt set /chosen/dom0 reg <${kernel_addr_r} 0x${filesize} >
-
-@@KERNEL_BOOTCMD@@ ${xen_addr_r} - ${fdt_addr}
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend
deleted file mode 100644
index 1e9f47d23..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend
+++ /dev/null
@@ -1,18 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-
-SRC_URI:append =" \
- ${@bb.utils.contains('AGL_XEN_WANTED','1',' file://boot_xen.cmd','',d)} \
-"
-
-do_compile:append() {
-
- # if xen feature is activated we overwirte the boot script with xen specific one
- if [ "${AGL_XEN_WANTED}" = "1" ]; then
- sed -e 's/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/' \
- -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/' \
- -e 's/@@MACHINE@@/${MACHINE}/' \
- "${WORKDIR}/boot_xen.cmd" > "${WORKDIR}/boot.cmd"
-
- mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
- fi
-} \ No newline at end of file
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
deleted file mode 100644
index ccaefc715..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-DESCRIPTION = "Boot script for launching OTA-enabled images on raspberrypi"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-DEPENDS = "u-boot-mkimage-native"
-
-COMPATIBLE_MACHINE = "raspberrypi"
-
-SRC_URI = "file://boot.scr \
- file://uEnv.txt \
- file://uEnv.cma.txt \
- "
-
-S = "${WORKDIR}"
-
-inherit deploy
-
-do_deploy() {
- install -d ${DEPLOYDIR}/bcm2835-bootfiles
-
- mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "Ostree boot script" -d ${S}/boot.scr ${DEPLOYDIR}/bcm2835-bootfiles/boot.scr
- if [ "${ENABLE_CMA}" = "1" ]; then
- install -m 0755 ${S}/uEnv.cma.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt
- else
- install -m 0755 ${S}/uEnv.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt
- fi
-}
-
-addtask deploy before do_package after do_install
-do_deploy[dirs] += "${DEPLOYDIR}/bcm2835-bootfiles"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr
deleted file mode 100644
index dc13f85b2..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr
+++ /dev/null
@@ -1,3 +0,0 @@
-fatload mmc 0:1 $loadaddr /uEnv.txt
-env import -t $loadaddr $filesize
-run bootcmd
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.cma.txt b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.cma.txt
deleted file mode 100644
index 062bddb93..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.cma.txt
+++ /dev/null
@@ -1,21 +0,0 @@
-bootcmd_resetvars=setenv kernel_image; setenv bootargs; setenv kernel_image2; setenv bootargs2
-bootcmd_otenv=run bootcmd_resetvars; load mmc 0:2 $loadaddr /boot/loader/uEnv.txt; env import -t $loadaddr $filesize
-bootcmd_rollbackenv=setenv kernel_image ${kernel_image2}; setenv bootargs ${bootargs2}
-
-bootcmd_args=setenv bootargs "$bootargs $bootargs_fdt ostree_root=/dev/mmcblk0p2 root=/dev/ram0 rw rootwait rootdelay=2 ramdisk_size=8192 panic=1 coherent_pool=6M smsc95xx.turbo_mode=N"
-
-bootcmd_getroot=setexpr ostree_root gsub "^.*ostree=([^ ]*).*$" "\\\\1" "${bootargs}";
-
-bootcmd_fitconf=run bootcmd_getroot; if test -e mmc 0:2 "${ostree_root}/usr/lib/fit_conf"; then load mmc 0:2 $loadaddr "${ostree_root}/usr/lib/fit_conf"; env import -t $loadaddr $filesize; fi
-
-bootcmd_load=load mmc 0:2 $ramdisk_addr_r "/boot"$kernel_image
-bootcmd_run=bootm "${ramdisk_addr_r}${fit_conf}"
-
-bootcmd_create_envfile=if test ! -e mmc 0:1 uboot.env; then saveenv; fi;
-
-bootlimit=3
-
-bootcmd=if test "${rollback}" = "1"; then run altbootcmd; else run bootcmd_create_envfile; run bootcmd_otenv; run bootcmd_args; run bootcmd_fitconf; run bootcmd_load; run bootcmd_run; if ! "${upgrade_available}" = "1"; then setenv upgrade_available 1; saveenv; fi; reset; fi
-
-bootcmd_set_rollback=if test ! "${rollback}" = "1"; then setenv rollback 1; setenv upgrade_available 0; saveenv; fi
-altbootcmd=run bootcmd_create_envfile; run bootcmd_otenv; run bootcmd_set_rollback; if test -n "${kernel_image2}"; then run bootcmd_rollbackenv; fi; run bootcmd_args; run bootcmd_fitconf; run bootcmd_load; run bootcmd_run; reset
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt
deleted file mode 100644
index 436fe95fe..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt
+++ /dev/null
@@ -1,21 +0,0 @@
-bootcmd_resetvars=setenv kernel_image; setenv bootargs; setenv kernel_image2; setenv bootargs2
-bootcmd_otenv=run bootcmd_resetvars; load mmc 0:2 $loadaddr /boot/loader/uEnv.txt; env import -t $loadaddr $filesize
-bootcmd_rollbackenv=setenv kernel_image ${kernel_image2}; setenv bootargs ${bootargs2}
-
-bootcmd_args=setenv bootargs "$bootargs $bootargs_fdt ostree_root=/dev/mmcblk0p2 root=/dev/ram0 rw rootwait rootdelay=2 ramdisk_size=8192 panic=1"
-
-bootcmd_getroot=setexpr ostree_root gsub "^.*ostree=([^ ]*).*$" "\\\\1" "${bootargs}";
-
-bootcmd_fitconf=run bootcmd_getroot; if test -e mmc 0:2 "${ostree_root}/usr/lib/fit_conf"; then load mmc 0:2 $loadaddr "${ostree_root}/usr/lib/fit_conf"; env import -t $loadaddr $filesize; fi
-
-bootcmd_load=load mmc 0:2 $ramdisk_addr_r "/boot"$kernel_image
-bootcmd_run=bootm "${ramdisk_addr_r}${fit_conf}"
-
-bootcmd_create_envfile=if test ! -e mmc 0:1 uboot.env; then saveenv; fi;
-
-bootlimit=3
-
-bootcmd=if test "${rollback}" = "1"; then run altbootcmd; else run bootcmd_create_envfile; run bootcmd_otenv; run bootcmd_args; run bootcmd_fitconf; run bootcmd_load; run bootcmd_run; if ! "${upgrade_available}" = "1"; then setenv upgrade_available 1; saveenv; fi; reset; fi
-
-bootcmd_set_rollback=if test ! "${rollback}" = "1"; then setenv rollback 1; setenv upgrade_available 0; saveenv; fi
-altbootcmd=run bootcmd_create_envfile; run bootcmd_otenv; run bootcmd_set_rollback; if test -n "${kernel_image2}"; then run bootcmd_rollbackenv; fi; run bootcmd_args; run bootcmd_fitconf; run bootcmd_load; run bootcmd_run; reset
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
index c5edbe1dc..464ae3f6f 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
@@ -1,16 +1,13 @@
SUMMARY = "Combine dtb and dtbo"
DESCRIPTION = "Combine specified dtb and one or more dtbo into specified filename found in deploydir"
SECTION = "bootloader"
-PR = "r1"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
DEPENDS = "dtc-native"
-ALLOW_EMPTY:${PN} = "1"
-FILES:${PN} = ""
-
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
do_compile[depends] += "virtual/kernel:do_deploy"
@@ -41,3 +38,6 @@ do_deploy () {
}
addtask deploy after do_install
+
+ALLOW_EMPTY:${PN} = "1"
+FILES:${PN} = ""