summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend4
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini19
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend6
3 files changed, 4 insertions, 25 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
new file mode 100644
index 000000000..14b858d45
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -0,0 +1,4 @@
+# Disable LVDS
+WESTONOUTPUT2[agl_screen] ??= "SCREEN_DSI"
+
+WESTONSECTION[WESTONOUTPUT2] = "output"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini
deleted file mode 100644
index 15721e3dc..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini
+++ /dev/null
@@ -1,19 +0,0 @@
-[core]
-backend=drm-backend.so
-shell=ivi-shell.so
-
-[ivi-shell]
-ivi-module=ivi-controller.so
-ivi-input-module=ivi-input-controller.so
-
-# HDMI / GeChic
-[output]
-name=HDMI-A-1
-transform=270
-# Uncomment for 1080p on GeChic 1502i:
-#mode=173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
-
-# official touchscreen over DSI interface
-[output]
-name=DSI-1
-transform=270
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
index 7c8167961..f8c0a5fa3 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
@@ -1,20 +1,14 @@
FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
- file://weston-raspberrypi.ini \
file://weston.sh \
"
do_install_append() {
- WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
- install -d ${D}${WESTON_INI_CONFIG}
- install -m 0644 ${WORKDIR}/weston-raspberrypi.ini ${D}${WESTON_INI_CONFIG}/weston.ini
-
install -d ${D}/${sysconfdir}/profile.d
install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
}
FILES_${PN} += " \
- ${sysconfdir}/xdg/weston/weston.ini \
${sysconfdir}/profile.d/weston.sh \
"