summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3-adas/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3-adas/conf')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/conf/NOTES74
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf67
2 files changed, 79 insertions, 62 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/conf/NOTES b/meta-agl-bsp/meta-rcar-gen3-adas/conf/NOTES
new file mode 100644
index 000000000..f9cb5b1e4
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/conf/NOTES
@@ -0,0 +1,74 @@
+#### These are notes for future reference
+
+# TODO: follow-up patch: Need to do other mechanism for package inclusion
+# TODO2: include or leave-out the kernel modules packages
+
+# E.g. MACHINE_FEATURE. Should *not* be in layer.conf !!
+# Radio packages
+#IMAGE_INSTALL_append_rcar-gen3 += " \
+# si-tools \
+# si-init \
+# linux-firmware-wl18xx \
+# ti-bt \
+# ti-bt-firmware \
+# bluez5 \
+# bluez5-testtools \
+# ofono \
+# ofono-tests \
+#"
+# E.g. MACHINE_FEATURE
+#IMAGE_INSTALL_append_r8a7797 += " \
+# kernel-module-uio-imp \
+# kernel-module-cmemdrv \
+# udev-rules-cvlib \
+#"
+# E.g. MACHINE_FEATURE
+#IMAGE_INSTALL_append_r8a7798 += " \
+# kernel-module-uio-imp \
+# kernel-module-cmemdrv \
+# udev-rules-cvlib \
+#"
+# This is a special use case. Should be enabled by user.
+#DISTRO_FEATURES_append = " surroundview "
+
+
+#### BBMASK
+# not required for AGL
+BBMASK += "/meta-rcar-gen3-adas/recipes-benchmark/"
+
+# Do not interfer with the distro configuration
+BBMASK += "/meta-rcar-gen3-adas/recipes-connectivity/bluez/"
+
+# We do not need the network config done here
+BBMASK += "/meta-rcar-gen3-adas/recipes-core/systemd/"
+
+# These changes are applied unconditionally when the layer is present.
+# These are not required for AGL
+BBMASK += "/meta-rcar-gen3-adas/recipes-core/images/"
+BBMASK += "/meta-rcar-gen3-adas/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend"
+
+# Upstream does have this change already, so this is not required.
+# poky/meta/classes/cmake.bbclass: -DCMAKE_NO_SYSTEM_FROM_IMPORTED=1
+BBMASK += "/meta-rcar-gen3-adas/recipes-devtools/cmake/"
+
+# Upstream has a more recent valgrind (3.15.0 vs 3.12.0)
+BBMASK += "/meta-rcar-gen3-adas/recipes-devtools/valgrind/"
+
+# This is already part of upstream and no bbappend is required
+BBMASK += "/meta-rcar-gen3-adas/recipes-devtools/gcc/"
+
+# libpng in upstream already enabled neon
+# poky/meta/recipes-multimedia/libpng/libpng_1.6.37.bb:EXTRA_OECONF_append_class-target = " ${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off" ,d)}"
+BBMASK += "/meta-rcar-gen3-adas/recipes-graphics/libpng/"
+
+# opencv in upstream is newer
+BBMASK += "/meta-rcar-gen3-adas/recipes-graphics/opencv/"
+
+# unclear patch status
+BBMASK += "/meta-rcar-gen3-adas/recipes-graphics/wayland/"
+
+# not required in AGL
+BBMASK += "/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/"
+
+# not required in AGL
+BBMASK += "/meta-rcar-gen3-adas/recipes-support/"
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf b/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
index 6d8d1dafb..343564501 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
@@ -2,74 +2,17 @@
BBPATH .= ":${LAYERDIR}"
# We have a recipes directory, add to BBFILES
+# 1) the first directory symlinks necessary files out of the cogent repo
+# 2) the 2nd directory is our local glue and appends
BBFILES += " \
- ${LAYERDIR}/../../../bsp/meta-rcar/meta-rcar-gen3-adas/recipes-*/*/*.bb \
- ${LAYERDIR}/../../../bsp/meta-rcar/meta-rcar-gen3-adas/recipes-*/*/*.bbappend \
+ ${LAYERDIR}/cogent-symlinks/recipes-*/*/*.bb \
+ ${LAYERDIR}/cogent-symlinks/recipes-*/*/*.bbappend \
${LAYERDIR}/recipes-*/*/*.bb \
${LAYERDIR}/recipes-*/*/*.bbappend \
"
BBFILE_COLLECTIONS += "rcar-gen3-cogent"
-BBFILE_PATTERN_rcar-gen3-cogent := "^${LAYERDIR}/../../../bsp/meta-rcar/meta-rcar-gen3-adas/"
+BBFILE_PATTERN_rcar-gen3-cogent := "^${LAYERDIR}/cogent-symlinks/"
BBFILE_PRIORITY_rcar-gen3-cogent = "7"
LAYERSERIES_COMPAT_rcar-gen3-cogent = "dunfell"
-
-# Custom packages
-IMAGE_INSTALL_append_rcar-gen3 = " \
- can-utils \
- libsocketcan \
- spidev-dbg spidev-test \
- e2fsprogs \
- e2fsprogs-tune2fs \
- ethtool \
- pciutils \
- usbutils \
- mtd-utils \
- capture \
- v4l2-fw \
- iperf3 \
- bonnie++ \
- lmbench \
- eglibc-utils \
- mm-init \
- iio-utils \
- most-tools \
-"
-
-# Radio packages
-IMAGE_INSTALL_append_rcar-gen3 += " \
- si-tools \
- si-init \
- linux-firmware-wl18xx \
- ti-bt \
- ti-bt-firmware \
- bluez5 \
- bluez5-testtools \
- ofono \
- ofono-tests \
-"
-
-# IMP
-IMAGE_INSTALL_append_r8a7797 += " \
- kernel-module-uio-imp \
- kernel-module-cmemdrv \
- udev-rules-cvlib \
-"
-
-IMAGE_INSTALL_append_r8a7798 += " \
- kernel-module-uio-imp \
- kernel-module-cmemdrv \
- udev-rules-cvlib \
-"
-
-DISTRO_FEATURES_append = " surroundview "
-DISTRO_FEATURES_append = " bluetooth"
-
-
-BBMASK += "/meta-rcar-gen3-adas/recipes-core/systemd/"
-BBMASK += "/meta-rcar-gen3-adas/recipes-graphics/opencv/"
-BBMASK += "/meta-rcar-gen3-adas/recipes-devtools/valgrind/"
-
-# cogent is incompatible with YP 3.1.1
-BBMASK += "meta-rcar-gen3-adas/recipes-bsp/linux-firmware/linux-firmware_20200122.bbappend"
8 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542