summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/ti-bt/ti-bt/ti-uim.service10
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/ti-bt/ti-bt_%.bbappend15
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3.bb35
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3/boot.cmd4
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-core/packagegroups/packagegroup-agl-core-connectivity.bbappend5
5 files changed, 69 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/ti-bt/ti-bt/ti-uim.service b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/ti-bt/ti-bt/ti-uim.service
new file mode 100644
index 000000000..214e60707
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/ti-bt/ti-bt/ti-uim.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=User Mode Init Manager for TI shared transport
+Before=bluetooth.service
+
+[Service]
+ExecStartPre=-/sbin/modprobe -q btwilink
+ExecStart=/usr/bin/uim -f /sys/devices/platform/kim
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/ti-bt/ti-bt_%.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/ti-bt/ti-bt_%.bbappend
new file mode 100644
index 000000000..45138b618
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/ti-bt/ti-bt_%.bbappend
@@ -0,0 +1,15 @@
+inherit systemd
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://ti-uim.service"
+
+SYSTEMD_SERVICE_${PN} = "ti-uim.service"
+
+do_install_append() {
+ # We do not want the blacklist
+ rm -f ${D}/${sysconfdir}/modprobe.d/ti_bt.conf
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/ti-uim.service ${D}${systemd_unitdir}/system
+}
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3.bb b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3.bb
new file mode 100644
index 000000000..42a05ec26
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3.bb
@@ -0,0 +1,35 @@
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = "u-boot-mkimage-native"
+
+SRC_URI = "file://boot.cmd"
+
+inherit deploy
+
+do_mkimage () {
+ uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
+ -n "boot script" -d ${WORKDIR}/boot.cmd ${WORKDIR}/boot.scr
+}
+
+addtask mkimage after do_compile before do_install
+
+do_compile[noexec] = "1"
+
+do_install () {
+ install -D -m 644 ${WORKDIR}/boot.scr ${D}/boot/boot.scr
+}
+
+do_deploy () {
+ install -D -m 644 ${WORKDIR}/boot.scr \
+ ${DEPLOYDIR}/boot.scr-${MACHINE}-${PV}-${PR}
+
+ cd ${DEPLOYDIR}
+ rm -f boot.scr-${MACHINE}
+ ln -sf boot.scr-${MACHINE}-${PV}-${PR} 6x_bootscript-${MACHINE}
+}
+
+addtask deploy after do_install before do_build
+
+FILES_${PN} += "/"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3/boot.cmd b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3/boot.cmd
new file mode 100644
index 000000000..61a7a925e
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-script-rcar-gen3/boot.cmd
@@ -0,0 +1,4 @@
+setenv bootargs console=ttySC0,115200 root=/dev/mmcblk0p1 rootwait ro rootfstype=ext4
+ext4load mmc 0:1 0x48000000 /boot/${fdtfile}
+ext4load mmc 0:1 0x48080000 /boot/Image
+booti 0x48080000 - 0x48000000
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-core/packagegroups/packagegroup-agl-core-connectivity.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-core/packagegroups/packagegroup-agl-core-connectivity.bbappend
new file mode 100644
index 000000000..01a7a9a41
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-core/packagegroups/packagegroup-agl-core-connectivity.bbappend
@@ -0,0 +1,5 @@
+RDEPENDS_${PN} += "\
+ linux-firmware-wl18xx \
+ ti-bt \
+ si-tools \
+"